WordPress.org

Ready to get started?Download WordPress

Forums

NextScripts: Social Networks Auto-Poster
[closed] Save your money. (6 posts)

4 stars
  1. gellenburg
    Member
    Posted 10 months ago #

    Edit: I've since had a change of heart and am changing my review. My original review is at the bottom.

    ----- UPDATED REVIEW -----
    Circumstances had required me to reinstall WP & plugins. Went to reinstall 3.2.1 on WP 3.8.1 and had the same problems with AJAX "-1" errors on the settings page.

    While I think the support could have gone better, ultimately the developer was able to find the problem and release ver. 3.2.2. This introduced a new problem however.

    After giving the developer login credentials to the site, he was able to see first-hand the problem, provided a workaround, and indicated the problem will be fixed in the next version.

    Perhaps I was a little too harsh in my original review. After all, most WP developers are usually one or two guys whose passion is WP and extending WP. Not making any excuses, but in my defense I wouldn't have been so upset originally if I hadn't just laid out $150 for the plugin. For $150 you expect something that "works". (Dear mods - yes I know this is the support forum for the non-commercial version of the plugin, but the same problems that have plagued the pro version also plague the free version.)

    So I'm revising my review. I won't give this plugin 5 stars, because while it may be a tremendous time-saver, it's just too flaky, and the development lifecycle is too… unpredictable.

    Personally I think this should be split out to make the codebase easier for the developer to work with. Have a main plugin and separate plugins for each social network that way when an API changes in twitter you only have to update one small plugin and not the behemoth.

    Anyway, these are my words, and I stand behind them.

    ----- ORIGINAL REVIEW -----
    I gotta say I'm incredibly disappointed and frustrated with this plugin.

    I've been fighting with this plugin now for over a week, have had to open about a half-dozen tickets with the plugins' author, and have even had to resort to posting here since he took down the forums on his website. I can honestly say that I'm ashamed to admit I forked over the $150 for the WPMU version.

    My heartfelt honest advice?

    Save your money.

    Consider using IFTTT instead. It allows you to automatically setup recipes and connections to the same social networks and can automatically post from all of your blogs (WPMU or not) based on when you publish a new post.

    Honest to God I wish I could get a refund.

    This is a great concept, but poorly executed in my opinion.

  2. NextScripts
    Member
    Plugin Author

    Posted 9 months ago #

    Please update to the version 3.0.3. Broken WPMU functions has been fixed there.

    Please let me know if you have any questions.
    Ludwig Van Normainen
    NextScripts.com

  3. gellenburg
    Member
    Posted 9 months ago #

    Still no dice.

    Unable to save any new account in the Main Account() -> Your Social Network Accounts tab.

    And lest you think this might be caused by my browser's cache or cookie problem, I make it a point of browsing in Incognito mode in Chrome full-time as I'd rather not have my browsing history and cookies lingering around to be snarfed up by Google or some other plugin/ script.

    In other words, I don't have a browser cache to worry about, and my cookies are cleared each time I shut down my browser.

    3.0.3 is still broken from what I can tell.

    This is what was in the logs:

    Y:[2013-11-03 15:17:45] - [Skipped]- Excluded Post Type:(Post ID: 364)
    [2013-11-03 15:17:43] - [*** ID: 364 Type: nav_menu_item],fr- Status Changed: draft_to_publish. Autopost requested.
    [2013-11-03 15:15:23] - [*** ID: 235, Type: page]- Status Changed: trash_to_publish. Autopost requested.
    [2013-11-03 15:15:22] - [*** ID: 244, Type: page]- Status Changed: trash_to_publish. Autopost requested.
    [2013-11-03 15:15:21] - [*** ID: 238, Type: page]- Status Changed: trash_to_publish. Autopost requested.
    [2013-11-03 15:15:21] - [*** ID: 260, Type: page]- Status Changed: trash_to_publish. Autopost requested.
    [2013-11-03 15:15:20] - [*** ID: 259, Type: page]- Status Changed: trash_to_publish. Autopost requested.
    [2013-11-03 15:15:19] - [*** ID: 241, Type: page]- Status Changed: trash_to_publish. Autopost requested.
    [2013-11-03 15:14:16] - [*** ID: 250, Type: page]- Status Changed: trash_to_publish. Autopost requested.
    [2013-11-03 15:14:16] - [*** ID: 235, Type: page]- Status Changed: trash_to_publish. Autopost requested.
    [2013-11-03 15:14:15] - [*** ID: 244, Type: page]- Status Changed: trash_to_publish. Autopost requested.
    [2013-11-03 15:14:13] - [*** ID: 238, Type: page]- Status Changed: trash_to_publish. Autopost requested.
    [2013-11-03 15:14:13] - [*** ID: 260, Type: page]- Status Changed: trash_to_publish. Autopost requested.
    [2013-11-03 15:14:12] - [*** ID: 275, Type: page]- Status Changed: trash_to_publish. Autopost requested.
    [2013-11-03 15:14:10] - [*** ID: 247, Type: page]- Status Changed: trash_to_publish. Autopost requested.
    [2013-11-03 15:14:10] - [*** ID: 259, Type: page]- Status Changed: trash_to_publish. Autopost requested.
    [2013-11-03 15:14:09] - [*** ID: 241, Type: page]- Status Changed: trash_to_publish. Autopost requested.
    [2013-11-03 15:07:45] - [Start =- ]- ------=========#### NEW AUTO-POST REQUEST BlogID:6 PostID:(527) Automated ####=========------
    [2013-11-03 15:07:44] - [*** ID: 527, Type: post]- Status Changed: draft_to_publish. Autopost requested.
    [2013-11-03 14:21:33] - [E],it [------=========#### API UPDATED ####== Array ( [method] => POST [timeout] => 45 [blocking] => 1 [headers] => Array ( ) [body] => Array ( [lk] => ] -
    0

    But nothing is showing in the Your Social Network Accounts window.

  4. NextScripts
    Member
    Plugin Author

    Posted 9 months ago #

    >> Unable to save any new account in the Main Account() -> Your Social Network Accounts tab.

    What is your API version? This sounds like something that could be caused by API earlier then 2.10.3.

  5. gellenburg
    Member
    Posted 9 months ago #

    If you refer to the ticket I originally opened on this issue, #529151, it was 2.10.0MU.

    Which by the way you never seem to respond to any follow-up questions on any of your tickets.

    Never did get a response to my follow up on Ticket #995375.

  6. I can honestly say that I'm ashamed to admit I forked over the $150 for the WPMU version.

    As this is a conversation regarding the commercial version please take it up on the authors site instead.

    http://www.nextscripts.com/support/

    Commercial products are not supported in these forums.

    @NextScripts? It would really be helpful if you directed users to that URL. These commercial support topics do not belong on these forums.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.