WordPress.org

Ready to get started?Download WordPress

Forums

Frontpage publishing no longer works after adding permalink code to .htaccess (4 posts)

  1. robmarkg
    Member
    Posted 6 years ago #

    Hi,

    I have installed WordPress on my site at http://www.caltrade.com/news . To make the permalinks work I followed the instructions and put the following code in my .htaccess file:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /news/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /news/index.php [L]

    I didn't know why at first, but suddenly I couldn't publish via Frontpage and got this message:

    403 Forbidden
    Forbidden You don't have permission to access /_vti_bin/shtml.exe/_vti_rpc on this server. Apache/2.0.52 (Red Hat) Server at http://www.caltrade.com Port 80

    When I removed that code from the .htaccess file, my FrontPage publising worked fine again. Will it be possible to configure this so that I can have both FrontPage publishing and WordPress publishing with permalinks? Please let me know how to modify this code to make it work, if that is possible.

    Thank you

    Rob

  2. Chris_K
    Member
    Posted 6 years ago #

    Have a look at the Permalinks page in the codex, in particular, scroll down to the FrontPage section. That should get you rolling.

  3. robmarkg
    Member
    Posted 6 years ago #

    Hi HandySolo,

    I was almost ready to come here and give you a virtual high five, but I couldn't get it to work. I followed the instructions on that link and put "Options +FollowSymlinks" in the .htacess file of the _vti_bin, _vti_adm, and _vti_aut directories (actually, it was already there). Then I modifed the root .htaccess file with the WordPress code. The text of this file is below and the perma-links work great at http://www.caltrade.com/news but, you guessed it, Frontpage publishing no longer works. In the code below, I put the WordPress code at the bottom, but have tried a few different permutations nothing seems to work. I hope I am not condemned to a life of constantly cutting and pasting this code to make my Frontpage publishing work. Does anyone know if there is some way I can tweek this code to make it work, or if there is some other solution.

    Thank you

    Rob

    ------------

    Options +FollowSymlinks

    # -FrontPage-

    IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*

    <Limit GET POST>
    order deny,allow
    deny from all
    allow from all
    </Limit>
    <Limit PUT DELETE>
    order deny,allow
    deny from all
    </Limit>
    AuthName caltrade.com
    AuthUserFile /var/www/vhosts/CALTRADE.com/httpdocs/_vti_pvt/service.pwd
    AuthGroupFile /var/www/vhosts/CALTRADE.com/httpdocs/_vti_pvt/service.grp
    php_flag register_globals on

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /news/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /news/index.php [L]
    </IfModule>

  4. cntowerlights
    Member
    Posted 6 years ago #

    Wow that's kind of upsetting. I was scrolling down the topic expecting a resolution at the end but nothing.

    So no way to get this to work eh? I'm having all the same problems.

Topic Closed

This topic has been closed to new replies.

About this Topic