WordPress.org

Ready to get started?Download WordPress

Forums

Quark
[resolved] Front page widgets missing (6 posts)

  1. jonescnl
    Member
    Posted 1 year ago #

    Hello,
    I am setting up the Quark theme and have tried to add the 4 widget areas below the main content as you mentioned above. But they are not displaying. I have added the meteor slider and a text widget to the banner area and the footer text widgets are working fine. But when I try to insert the text widgets in the content area ...no show. Any help for me? Nice theme by the way!!!!!!!

  2. ahortin
    Member
    Theme Author

    Posted 1 year ago #

    You need to make sure you change the template on the Page that you created for the homepage, so that it's using the Front Page Template.

    Have a look at the updated FAQ's on the theme homepage and you'll see the steps you need to follow to setup your static homepage correctly.

  3. jonescnl
    Member
    Posted 1 year ago #

    Thanks. I missed a step. It's working fine now.

    First up, your need to change your sites Front Page so that it’s displaying a Static Page, rather than your latest posts. You do this within the SETTINGS > READING page. For the option ‘Front page displays’, select ‘A static page’ and then select the Page you want to display for the homepage and the page you want to use for your blog posts.

    I missed the step below

    When creating the page to use for your ‘Front Page’, make sure to set the template to Front Page Template using the ‘Template’ dropdown list in the Page Attributes panel on the right of the page.

    Next, in the APPEARANCE > WIDGETS page, add a text widget to the First Front Page Banner Widget. Add a title to the text widget and in the content area, I added the following:

    <h2>Your basic building block for creating beautiful, responsive custom themes built on HTML5 & CSS3</h2>
    <p>Call to action!</p>

    You can obviously change the text as you please and add a proper url to the link.

    In the Second Front Page Banner Widget I just added another text widget and added the following img html tag:

    <img src="insert-your-image-url-here" alt="Add your img ALT text in here" />

    You could also use something like this Image Widget plugin. It’s a great little plugin that allows you to add images to your widgets really easily.

    The three widget areas below the main content are simply text widgets again, added to the First Front Page Widget Area, Second Front Page Widget Area and Third Front Page Widget Area.

  4. ahortin
    Member
    Theme Author

    Posted 1 year ago #

    No probs. Glad you got it sorted :-)

  5. AudreyWP
    Member
    Posted 6 months ago #

    I'm working with U-Design Theme for WordPress.
    I do not see a "Front Page Template"
    On all my pages settings in the "Page Attributes" > "Templates" section it does not appear "Front Page Template" option?
    It only appears, Default Template, Archives, Blog Page, Contact page, Full-Width page, Page Template 2,....
    But not, "Front Page Template".
    Can you help me with this?
    I can not have any Home Page Widgets on my Home page being an static page.
    Please help! :'((

  6. AudreyWP
    Member
    Posted 6 months ago #

    Sorry,
    I guess I posted the above note on the wrong tread... :p

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags

No tags yet.