WordPress.org

Ready to get started?Download WordPress

Forums

front page problem (6 posts)

  1. torinschmitt
    Member
    Posted 4 years ago #

    Hello all,
    I am having a problem with my front page not showing any posts. I specify the posts and front page under the 'READING' section but nothing seems to work. I've created a fresh page called 'MAIN' and I set it to be the posts and front page as well but that didn't help either. If I go to the root of the site, I can see all my posts but it just won't allow me to specify which page is the front page or posts page. The root of the site is http://diversionweb.com/torinschmitt

    Do any of you understand why this is happening?
    Thank you!

  2. doc4
    Member
    Posted 4 years ago #

    torinschmitt,

    The root is defaulting to the about us page. Double check your settings. The home page needs to be the Main Index Page ( index.php ) in order to be seen as the root home page.

  3. Mohit Kumar
    Member
    Posted 4 years ago #

    In your admin panel

    goto settings -> reading settings

    make a front page as 'home' this may contain any introductory text.
    move your blog post into page 'main' and now try.

  4. torinschmitt
    Member
    Posted 4 years ago #

    Thanks guys. I'm not sure I follow. I created a new page called "home" and set my front page and posts page to home but no luck there either. doc4, I know you are saying that the home page needs to be the main index page but how do I make that change?
    Thank you!

  5. Mohit Kumar
    Member
    Posted 4 years ago #

    Hey can you answer me these questions - just tell us what is the setting in your seeting->reading page in admin panel

    The front page displays

    Have you selected (that means the yellow dot ) -

    A static page (select below) ??

    * Front page: what is value here??
    * Posts page: what is value here?/

    If you provide this i can surely help

  6. doc4
    Member
    Posted 4 years ago #

    torinschmitt,

    Go ahead and answer the above questions. WordPress, like any web site defaults to the index page, whether it is a .php or .html. You can try setting the Front Page and Post Page back to "- Select" But without knowing what you are doing this is a little difficult to answer.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.