WordPress.org

Ready to get started?Download WordPress

Forums

Front page not showing latest posts. (3 posts)

  1. jaimemagiera
    Member
    Posted 4 years ago #

    Hello,

    I'm completely new to wordpress. The setup here is wordpress, nginx and mysql. The wordpress install lives at /blog. I've nginx configured with...

    location /blog {
    passenger_enabled off;
    index index.html index.htm index.php;
    #try_files $uri $uri/ /blog/index.php?q=$uri;
    try_files $uri $uri/ /blog/index.php?q=$uri&$args;
    }
    location ~ \.php$ {
    fastcgi_index index.php;
    fastcgi_pass localhost:9000;
    fastcgi_param SCRIPT_FILENAME
    $document_root$fastcgi_script_name;
    include /opt/nginx/conf/fastcgi_params;
    }

    After the initial setup, I'm able to create posts and link to them. However, just going to the /blog index shows a "Not Found: :| sometimes this happens" error instead of a listing of the posts. The reading preferences are set to "latest posts". I'm sure this is something simple I've overlooked.

    thanks for any advice,

    Jaime

  2. jaimemagiera
    Member
    Posted 4 years ago #

    Ok, another bit of information. The site currently uses a custom theme. If I switch to the default theme, the posts show as expected. I'm unfamiliar with the inner workings of themes. If anyone has suggestions on what aspect of a theme interacts with the front page, that might give me some place to start looking. I've contacted the developers of the theme and hope to hear back from them as well.

  3. Samuel B
    moderator
    Posted 4 years ago #

    the theme serves either an index.php or home.php as home page
    clicking on a post tile uses single.php and a page title uses page.php

Topic Closed

This topic has been closed to new replies.

About this Topic