WordPress.org

Ready to get started?Download WordPress

Forums

from domain.com/blog to domain.com (10 posts)

  1. felix479
    Member
    Posted 2 years ago #

    Hello,

    I'm not an advanced user and I'm at my second wordpress website.
    I've been installing WordPress, everything looked fine until I realized that my website redirects to domain name/blog and not to the actual domain name.
    I've been trying to find out what the issue is and tried several solutions but I really can't figure it out.
    I'm an absolute beginner but I understand the basics and I followed the instructions although I'm sure I missed something...

    Thank you in advance,
    Felix

  2. magnuscromulus
    Member
    Posted 2 years ago #

    Hi Felix, is this a local install or to some ISP?

  3. felix479
    Member
    Posted 2 years ago #

    Hello magnuscromulus, it's ISP.
    I modified the wp-config.php accordingly, tried several solutions like define('WP_HOME','http://example.com');
    define('WP_SITEURL','http://example.com');

    and others but the website is still appearing on domain name.com/blog despite the permalinks and general settings also well set up.

    I'm not sure about 2 steps I did in the install process:
    htaccess....I just copied and pasted it together with the other files within the FTP folder, whilst I remember there was something more to do with it (but can't recall what...)

    creation of database, I simply added the various login, psw, database name etc. on the wp-config file. The database is already created on my hosting, is that all correct?

    Cheers
    F.

  4. govpatel
    Member
    Posted 2 years ago #

    Where exactly do have your wordpress files and folder in blog folder or root as if you have wrong urls in Settings>>>General you should get error and get to your website.

  5. felix479
    Member
    Posted 2 years ago #

    the wordpress files are in root, the urls are correct on Settings > General but still, the main domain gets to a page "Under Construction" from the hosting solution I chose (ovh) and the website appears only if I add the /blog to the url...

  6. magnuscromulus
    Member
    Posted 2 years ago #

    Hi Felix,

    I don't know about your ISP - I used 1and1 and with 1and1 there is an administrator setting page where you can make sure that index.htm points to the right location.

    So the index.htm should point to your wordpress index.htm location

    In other words, I think your wordpress settings are probably correct, but the host settings are incorrect. let me see if i can get a screenshot for you later on so I can show you what I mean. In any case, a call to your ISP's support team can clear this out, I'm sure.

  7. magnuscromulus
    Member
    Posted 2 years ago #

    If you go to re-covered.net and click on "help for felix" you will see an image I uploaded for you to look at. In it you can see how re-covered.net points to right folder location.

  8. govpatel
    Member
    Posted 2 years ago #

    that under construction must a place holder page you can delete or rename the page most likely is index.html

  9. felix479
    Member
    Posted 2 years ago #

    @magnuscromulus: thanks a lot for your help

    @govpatel: yes indeed, I checked both ftp of my websites to compare one to the other and actually on the first one there was no index.html whilst on the second there was one related to the under construction page.
    I removed it and now the site runs on the right URL.

    Thanks to all, very nice of you :)

    Cheers
    Felix

  10. govpatel
    Member
    Posted 2 years ago #

    You are welcome

Topic Closed

This topic has been closed to new replies.

About this Topic