WordPress.org

Ready to get started?Download WordPress

Forums

fresh install - you do not have permission to access this page (8 posts)

  1. t-readyroc
    Member
    Posted 7 months ago #

    I've had to make changes in order to just get my site to work behind our kemps (off-loading SSL). I adapted the code from here to get the site working (added: $_SERVER['HTTPS']='on'; to wp-config.php).

    I can now access the site, but when I log in, I get the "you do not have permission" error. Then if I hit the site's home page, I get the admin bar; but I still can't access the dashboard (or any other admin area). Dev console is reporting a 500 server error, but I don't see anything more descriptive in the apache logs...

    I've moved the plugins folder, and I've changed the wp_capabilities value so far to no avail. I also just recreated the salt values which didn't help. I have not changed my db prefix since installation.

  2. Sandeep
    Member
    Posted 7 months ago #

    Is virtualhosts correctly defined for https/443 port? Put a simple html file and try accessing it via https, does it come up?

  3. t-readyroc
    Member
    Posted 7 months ago #

    Hey sandyr - yep, I just dropped a test.html file in there & was able to access it via https://www...etc

    I also just followed this procedure to create another admin user & that didn't help.

  4. Sandeep
    Member
    Posted 7 months ago #

    Enable wordpress debug logs. What's coming in there?

  5. t-readyroc
    Member
    Posted 7 months ago #

    I enabled debug, debug_log & debug_display in wp-config.php a while back to see if I could get anything, & got nothing. I then intentionally edited the code to introduce an error just to make sure it was working (redefined a constant). Logs haven't shown anything save for my intentional error, unfortunately.

  6. t-readyroc
    Member
    Posted 7 months ago #

    I actually just completely wiped out my installation; rm -rf the entire site root, dropped the database, complete recreation.

    Got the same error. Serenity now.

  7. t-readyroc
    Member
    Posted 7 months ago #

    This first part is returning false:

    function wp_validate_auth_cookie($cookie = '', $scheme = '') {
            if ( ! $cookie_elements = wp_parse_auth_cookie($cookie, $scheme) ) {
                    do_action('auth_cookie_malformed', $cookie, $scheme);
                    return false;
            }
  8. t-readyroc
    Member
    Posted 7 months ago #

    We were able to fix the issue by pasting the $_SERVER['HTTPS']='on'; at the beginning of wp-config.php instead of at the end. That was it. Ugh.

Reply

You must log in to post.

About this Topic

Tags

No tags yet.