WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] fresh install wordpress multisite permalink problem (2 posts)

  1. dorwardv
    Member
    Posted 3 years ago #

    Hi i just did a fresh install from both debian sid repo and source and both of these situations apply

    here are the screenshots of my procedure
    Installing WordPress
    Working About
    Working Hello World
    creating the network
    reflecting changes to configuration files
    About not found
    hello world not found

    config-hostname.php
    <?php
    
        define('DB_USER','xxxxxxx');
        define('DB_PASSWORD','yyyyy');
        define('DB_HOST','zzzzz');
        define('DB_NAME','myblogs');
        define('DB_CHARSET', 'utf8');
        define('DB_COLLATE', '');
    
        define( 'MULTISITE', true );
        define( 'SUBDOMAIN_INSTALL', false );
        $base = '/blogs/';
        define( 'DOMAIN_CURRENT_SITE', 'zzzzzz' );
        define( 'PATH_CURRENT_SITE', '/blogs/' );
        define( 'SITE_ID_CURRENT_SITE', 1 );
        define( 'BLOG_ID_CURRENT_SITE', 1 );
    
        define( 'AUTH_KEY', 'D}|6 hnxlEib;ecCp-p:kd0Ae<0ig/@#+R(5B7r+4pJ8)f [BqY)E;
    I=xEB.x@:' );
    define( 'SECURE_AUTH_KEY', '204?R|z=%SjRGW+%_rx;]5DbXX6Me~17of@&%6XDox)8lT3K:_B6J0Q2_MzN;]#^' );
    define( 'LOGGED_IN_KEY', 'fe(B/u(>QsL#^.EG{;@DVVwNFnXS)cfm6vF9^6~7i11r+%3u/^n(+*/Ld6|<,[Tr' );
    define( 'NONCE_KEY', 'zd]zy&wh252/UxR@@v(X<1}L)qk+W[H:z-CY5:lT>,%$89^{4T)>db3$[(&og!' );
    define( 'AUTH_SALT', 'fU( rCkVBd&`AiVr>0?LJ-W=;M8: T3IbleS;Z?_O;CU&?sO8BzAM275q(IB9%pA' );
    define( 'SECURE_AUTH_SALT', '3GV7Micx5FXK_u-C7{]%w3Ql,AatV?|B~#Rn{spmK,#[bc+j)1nuSKfI7+p}FuOp' );
    define( 'LOGGED_IN_SALT', 'C)1Y{![fsXjfRdEBkQDz|{fyZx4:_:i@9Ja|v|fh[WzEx_B;+zWHZZ963]_$-{@}' );
    define( 'NONCE_SALT', 'k#xlZEYgsndZoc?hOr2<g+0`SR|5x$an=TgJr!v(u$5+$b=5]-r [}C%J>0/x_se' );

    ?>`

    wp-config.php

    <?php
    /** WordPress's Debianised default master config file
    Please do NOT edit and read about how the configuration works in the README.Debian
    **/
    
        #http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=435289
        #http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=440572 (underscores, not dashes)
        $debian_server = preg_replace('/:.*/', "", $_SERVER['HTTP_HOST']);
        $debian_server = preg_replace("/[^a-zA-Z0-9.\-]/", "", $debian_server);
        $debian_file = '/etc/wordpress/config-'.strtolower($debian_server).'.php';
    
        if (!file_exists($debian_file)) {
            header("HTTP/1.0 404 Not Found");
    	echo "<b>$debian_file</b> could not be found. The file is either not readable by this process or does not exist. <br />
    		Please check if <b>$debian_file</b> exists and contains the right password/username.";
            exit(1);
        }
    
        require_once($debian_file);
    
    define('ABSPATH', '/usr/share/wordpress/');
    define('WP_CORE_UPDATE', false);
    define('WP_ALLOW_MULTISITE', true);
    define('DEBIAN_FILE', $debian_file);
    
    require_once(ABSPATH.'wp-settings.php');
    ?>

    htaccess

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blogs/
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    </IfModule>

    without creating the network, everything is fine.

    from debian unstable repo
    apache 2.2.16
    mysql-server 5.1.49
    php5 5.3.2

  2. dorwardv
    Member
    Posted 3 years ago #

    turns out that i didnt allow override for this directory.
    my apologies,

    dorwardv

Topic Closed

This topic has been closed to new replies.

About this Topic