WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Fresh install, already seeing problems (9 posts)

  1. RWS Brett
    Member
    Posted 2 years ago #

    Warning: copy(/home/public_html/blog/wp-content/uploads/2012/04/banner.jpg) [function.copy]: failed to open stream: Permission denied in /home/public_html/blog/wp-admin/includes/file.php on line 348

    Warning: getimagesize(/home/public_html/blog/wp-content/uploads/2012/04/banner.jpg) [function.getimagesize]: failed to open stream: No such file or directory in /home/public_html/blog/wp-admin/custom-header.php on line 665

    I JUST installed for the first time. Everything went smooth and then as soon as I wanted to upload a new header, I get these errors.

    [No bumping. If it's that urgent, consider hiring someone.]

  2. RWS Brett
    Member
    Posted 2 years ago #

    Using windows 7, PHP version 5.2.17, hosted server

  3. Caps
    Blocked
    Posted 2 years ago #

    I assume the operating system for the hosted server is linux.

    Try uploading an image, then insert it on a page. See if that works, report back.

  4. RWS Brett
    Member
    Posted 2 years ago #

    Caps wrote:

    I assume the operating system for the hosted server is linux.
    Try uploading an image, then insert it on a page. See if that works, report back.

    Can you please clarify what you mean? Upload an image to where, and insert it how.

  5. Caps
    Blocked
    Posted 2 years ago #

    Hi,

    These are very basic functions of WordPress. I suggest you sit down and read and watch some tutorials. :)

    In the dashboard you have an item at left named, Media. There you would upload an image to test if that routine is working properly.

  6. RWS Brett
    Member
    Posted 2 years ago #

    Caps wrote:

    Hi,
    These are very basic functions of WordPress. I suggest you sit down and read and watch some tutorials. :) In the dashboard you have an item at left named, Media. There you would upload an image to test if that routine is working properly.

    ah, I do understand, I was just unsure if you were referring to something else. didn't realize you meant from the admin ui. Easy.

    “image.jpg” has failed to upload due to an error
    Unable to create directory /home/public_html/blog/wp-content/uploads/2012/04. Is its parent directory writable by the server?

  7. esmi
    Forum Moderator
    Posted 2 years ago #

    Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767, 775 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.
    http://codex.wordpress.org/Changing_File_Permissions

  8. RWS Brett
    Member
    Posted 2 years ago #

    Awesome, that worked! I had to go all the way down to 777 to get it to work, and then I changed it back and they work fine! Thank you very much!

  9. esmi
    Forum Moderator
    Posted 2 years ago #

    You're welcome :-)

Topic Closed

This topic has been closed to new replies.

About this Topic