WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] FreeBSD, WordPress 2.7.x and TinyMCE (3 posts)

  1. asmodai
    Member
    Posted 5 years ago #

    Today I started to write a post while on my FreeBSD box. I'm using Firefox 3.0 and I noticed that TinyMCE is only showing me the HTML view of the editor. I cannot click visual at all.

    On Windows with Firefox 3.0 the same works without problems, so it is not the files in my install.

    When I went to the TinyMCE homepage I went to the 'full featured example' page and that worked without any problems.

    As such I am ruling out that my Firefox 3.0 on FreeBSD has any problems with JavaScript or TinyMCE's use of it. But what could it be, a bug in WordPress or the TinyMCE version included? Any help debugging this a bit would be appreciated before I log a bug report.

    Just checked with Opera 9.63 as well, same problem. It's like something is detecting 'freebsd' and not allowing to use the visual mode.

  2. asmodai
    Member
    Posted 5 years ago #

    Turns out, after the necessary debugging, that for some reason (GCC or cosmic rays) lighttpd 1.4.21 was not compiled well. It only happened on this particular file (tiny_mce.js). A forced recompile later (with exact the same options, flags and all) and everything works.

  3. asmodai
    Member
    Posted 5 years ago #

    Actually, it turns out it was a bug in lighttpd 1.4.21's handling of sendfile() on FreeBSD.

    For more details, see http://redmine.lighttpd.net/issues/1913

Topic Closed

This topic has been closed to new replies.

About this Topic