WordPress.org

Ready to get started?Download WordPress

Forums

FreeBSD setLocalte trouble (11 posts)

  1. XrV
    Member
    Posted 7 years ago #

    Hello :)

    I have a clean instalation of wordpress on a freeBSD webhosting. I upload the es_ES.mo translation and I configure the "define ('WPLANG', 'es_ES');" then the webpage appears in spanish (GREAT!), my surprise comes when i see the "DATE FORMATS" (mainly the months) because it appears in english, because the correct setLocale on freeBSD is not 'es_ES', is just 'es_ES.ISO8859-15' but if i change to the correct set locale for the spanish code, my web appears in english, and my dates appears in spanish.

    I figure that the only I need to do is change the setLocale var on the getText.php archive, but i'm a web developer and i know what to do, but you know that the wordpress blog is used by lots of people with a null knowledge of php or webscripting.

    This post is just to explain the "bug" and I proppose an implementation of two WPLANG vars (WPLANG and WPSETLOCALE), for example (one for the .mo and other for the date formats).

    Thanks for reading.
    Marc Palau

  2. yosemite
    Member
    Posted 7 years ago #

  3. XrV
    Member
    Posted 7 years ago #

    Your reply really offend me... maybe you only read "spanish" and your only one solution is tell me the poor spanish forums??. The problem is an incompatibility of wordpress setLocale with freeBSD (freeBSD doesn't use the linux way on locale string).

    Is not the same es_ES than es_ES.ISO8859-15 and the system don't translate correctly if I use the correct Locale code.

    thanks.
    Marc

    PS: maybe my english is poor, sorry for that.

  4. yosemite
    Member
    Posted 7 years ago #

    Some people wake up expecting to be offended. They are rarely let down.

    If you are unhappy with the resources available for localization in the Codex, perhaps you can help improve them?

    de nada

  5. Bricolou
    Member
    Posted 7 years ago #

    I've set up several WordPress blogs in french, and I've always had to set the date and time formats to local specifications in Options/General. For example, j/n/Y gives 3/8/2006 for today and H:i will show 18:11.
    Information on these settings can be found using the links in the Date/Time area of Options/general.
    Also, I've always used ISO-8859-1 in Options/read as UTF-8 doesn't give satisfactory results with accents.
    fr_FR goes in the config file, as such, nothing following.

  6. XrV
    Member
    Posted 7 years ago #

    oh Yosemite! great, another good reply. You'r not replying to my answer again.

    I'm offended because allways I try to solve a problem with English speakers they are mean to me or something similar.

    I know there are lot's of resources in Spanish, but I think this is a BUG on WordPress on a freeBSD server and I want to go to the base of the problem, not just speak with people who only ask "how to change the CSS" or "how can i install a template?".

    If you don't know how to solve this problem, just ignore my post. I think someone is playing the triangle here and it's not me.

    Bricolou, thanks for your serious reply.

    Best reggards and thanks again
    Marc

  7. XrV
    Member
    Posted 7 years ago #

    But Bricolou, the main problem is for the 'strftime' function, if I try to get the month in spanish, it only work with the es_ES.ISO8859-15 on setLocale, but if I configure on this, I get the blog on english (the translation don't work). If I reconfigure the WPLANG to es_ES, the translation work perfectly and the 'strftime' work in english.

    Are you using Win, Linux o freeBSD systems?

  8. Bricolou
    Member
    Posted 7 years ago #

    I'm on a linux server and not freeBSD. Sorry if my indications didn't help. But I don't quite understand why numbers like 02/05/2006 are less interesting for you than 2 May 2006 ? (translated into spanish of course).

  9. Bricolou
    Member
    Posted 7 years ago #

    XrV: Yeah, I know what you mean. Sorry if I haven't been helpful. I hope you find the info you want.

  10. XrV
    Member
    Posted 7 years ago #

    thanks a lot Bricolou, my last post go for Yosemite, not for you. I think that what you say is a good solution, but is not a final solution for a problem like this one.

    Thanks for the replys.
    Marc

  11. yosemite
    Member
    Posted 7 years ago #

    Welcome!

Topic Closed

This topic has been closed to new replies.

About this Topic