WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Formatting issues since upgrade to 2.1 (9 posts)

  1. posiesplace
    Member
    Posted 7 years ago #

    I recently upgraded my WordPress version to 2.1 and since then none of the formats in my posts seem to work properly.

    I used to have a standard way to set out my posts with text, a centered image, a <more> tag and then the rest of my text (not centered). Since upgrading none of this works. My images will no longer allow me to center them and the text will not allow me to place it underneath an image. You'll see what I mean if you look at any of my posts.

    I also noticed that when I turn off the WYSIWYG editor and look at the code that the <p> tags are being dropped in my posts. It doesn't matter if I apply them manually they are always dropped.. I guess these problems are related. I tried installing and using an alternative WYSIWYG plugin but this made no difference and so now I have disabled this plugin and have gone back to using the in-built version.

    Any ideas as to how I can fix this? This issue doesn't seem to have affected everyone who has upgraded.

  2. posiesplace
    Member
    Posted 7 years ago #

    Meant to say my website is http://www.posiesplace.net

  3. amucklow
    Member
    Posted 7 years ago #

    Hi

    I've just upgraded and am experiencing the same thing. My rich text editor appears not to be working as before, i.e. it's dropping </p> tags and refusing to render block-level <div> tags.

    Alastair

  4. posiesplace
    Member
    Posted 7 years ago #

    Take a look at this post

    http://wordpress.org/support/topic/101906?replies=49

    I have applied the following patch

    http://www.urbangiraffe.com/plugins/disable-wpautop/

    This will act as a pseudo fix allowing you to apply DIV tags manually but beware as if you try and re-edit the post your DIV tags will be replaced automatically by P tags once more.

    Really infuriating but it'll need to do until they issue a fix as I'm a complete novice messing with code and I don't want to mess things up completely.

    If anyone has any better ideas as to how to prevent the DIVs being replaced on modification of a post I would really appreciate the pointers.

    Thanks

  5. posiesplace
    Member
    Posted 7 years ago #

    Scratch my last post, although the patch will allow current post to be fixed it messed with all of the older posts so this isn't really a pseudo fix after all.

  6. amucklow
    Member
    Posted 7 years ago #

    Thanks anyway posiesplace. I've had to switch off the visual editor and write code manually. This allows me to add <div>s but still it adds rogue <p> tags which is messing with my img styling.

  7. posiesplace
    Member
    Posted 7 years ago #

    I tried that but things still look messed up!

  8. adriangab
    Member
    Posted 7 years ago #

    the rogue tags are killing me too. i've happily been using some code to create thumbnails but since the upgrade to 2.1, wordpress is adding <p> tags in places they i have coded it to.

    any suggestions, this is my post on the issue:
    http://wordpress.org/support/topic/105301

  9. adriangab
    Member
    Posted 7 years ago #

    My install of 2.1 was adding stupid P tags in places in shouldnt.

    But thankfully, I found this post:

    http://wordpress.org/support/topic/102799

    Check it out to see if it helps you.

Topic Closed

This topic has been closed to new replies.

About this Topic