WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Formatting a Page (10 posts)

  1. castlebri
    Member
    Posted 1 year ago #

    I'm trying to format a page so that the image is aligned left and has a caption under neath of it. It works for most images but then some images are doing something on their own (different alignment) and the text is being strange as well (bold, different alignments).

    Is there an easy way to resolve this?

    http://scribe.castlebri.com/clearance-materials/

  2. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Those items are using a list - which has different formatting in the CSS. How are you entering these items - is it part of your theme? Or an ecommerce plugin?

  3. castlebri
    Member
    Posted 1 year ago #

    I believe the person working on this is manually doing everything directly in the page via insert media then types in the text manually below. repeat steps for all images. I do not believe they are doing any coding in relation to the content.

  4. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    You can use a browser to View Source and see that the HTML code for those items is completely different:

    <div>
    <dl id="attachment_688">
    <dt>
    <a href="http://scribe.castlebri.com/wp-content/uploads/2012/11/floor6.jpg" onclick="javascript:pageTracker._trackPageview('/downloads/wp-content/uploads/2012/11/floor6.jpg');">
    </dt>
    <dt></dt>
    <dt></dt>
    <dt></dt>
    <dt></dt>
    <dt></dt>
    <dt>Cork Flooring</dt>
    <dt></dt>
    <dt>12’’x12’’ Expanko Castello (unfinished) cork Qty 51 $1.50/sqft</dt>
    </dl>

    To avoid the different formatting, he/she would ideally need to avoid using the list.

    The "normal" HTML is this:

    <p>
    <a href="http://scribe.castlebri.com/wp-content/uploads/2012/11/Sconce.jpg" onclick="javascript:pageTracker._trackPageview('/downloads/wp-content/uploads/2012/11/Sconce.jpg');">
    </p>

    Where is the theme from? It's hard to say from this end what's going on with the code or how the content is being entered.

  5. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    BTW, all those extra tags are not ideal either. They show up in both the "normal" and "list" items - does the person working on this know what he/she is doing?

  6. castlebri
    Member
    Posted 1 year ago #

    I have never uploaded pictures to our site with a need to update HTML/CSS for this page in the past which is why I had her do it. I'm not sure why all the tags are even there to begin with.

    The theme we are using is: Modern-Blue version 2.0

    I'm thinking best option is to start over on this page, or is there a potentially easier solution? Thoughts?

  7. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    I don't know how that theme works (these forums only support themes from the repository on this site), so really can't give you much specific advice - can you delete just those items that are formatted wrong?

  8. castlebri
    Member
    Posted 1 year ago #

    Understandable; I took over maintenance for this site just a few months ago and this template is not perfect by any means ha! It's given me multiple troubles over the months. I suppose I can delete and try re-uploading but the content has to be there one way or another as we are having a neighborhood business garage sale this weekend that these items will be at.

  9. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Yeah, it seems a bit odd. But there must be something that is causing it to put those items into a list - I'm sorry I can't be of more help with it.

    Of course, it's also possible that some plugin is doing strange things - so you could try deactivating those temporarily.

    Longer term, you really might want to find a more current, supported theme - I'm guessing that's a bigger project, but might be worth it in the long run.

  10. castlebri
    Member
    Posted 1 year ago #

    I'll have her delete / re-upload for now and see if that helps. Thanks for the insight, I'm just happy have received a response!!

    The only plug-ins that are currently active is: TanTanNoodles Simple Spam Filter and Ultimate Google Analytics. They could be interfering somehow but I'm thinking they are probably not the problem.

    We are looking at overhauling the website as a whole in the next year so I will probably just push through.

    Thanks for all the help!

Topic Closed

This topic has been closed to new replies.

About this Topic