WordPress.org

Ready to get started?Download WordPress

Forums

Ryu
Format image displaying wrong (15 posts)

  1. guanmu
    Member
    Posted 11 months ago #

    I just setup a personal blog.

    I post my first post with the format - image.

    Looks it dosen't works well, it's empty. check the effect as the link blow:
    http://guanmu.name/

    need your help to fix it.

    Thanks

  2. Kathryn
    Automattic Happiness Engineer
    Posted 11 months ago #

    Hi there, it looks like your post is there - I can see it if I scroll down - but it's being pushed down by some errors that you can see if you view the source of the page in your browser. Here's a portion of the errors:

    <b>Warning</b>:  imagecreatefromjpeg() [<a href='function.imagecreatefromjpeg'>function.imagecreatefromjpeg</a>]: http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in <b>/nfs/c04/h02/mnt/65272/domains/guanmu.name/html/wp-content/themes/ryu/inc/tonesque.php</b> on line <b>53</b><br />
    <br />
    <b>Warning</b>:  imagecreatefromjpeg(http://guanmu.name/wp-content/uploads/2013/09/Nexus7_2.jpg) [<a href='function.imagecreatefromjpeg'>function.imagecreatefromjpeg</a>]: failed to open stream: no suitable wrapper could be found in <b>/nfs/c04/h02/mnt/65272/domains/guanmu.name/html/wp-content/themes/ryu/inc/tonesque.php</b> on line <b>53</b><br />

    It looks like one of the theme's required PHP functions is disabled by your web host:

    wrapper is disabled in the server configuration by allow_url_fopen=0

    I would try contacting your host to see if they can enable this for you, and the errors should go away, allowing your site to display correctly.

    Let me know if you have any other questions.

  3. guanmu
    Member
    Posted 11 months ago #

    Thank you so much Kathryn! Your response is so quick.

    If it is display correctly, the image formate should also has a color background, right?

    Hope mediatemple can disable the PHP functions for me.

    Waiting for your good news.

    Best

  4. Kathryn
    Automattic Happiness Engineer
    Posted 11 months ago #

    Yes, the Ryu theme is designed to automatically change the background colour of image post types, using a special tool called Tonesque. It's that feature which is being prevented from running because of the function that's blocked by your web host. Hopefully they can fix that for you.

    Good luck!

  5. guanmu
    Member
    Posted 11 months ago #

    Hi Kathryn,

    I just talked with MediaTemple, this is the answer:
    You can add that variable by editing your php.ini. While we don't provide support for editing your php.ini, this article should demonstrate how to.

    http://kb.mediatemple.net/questions/137

    11:12 am Then, you can find more information regarding the PHP parameter allow_url_fopen in the KnowledgeBase article provided below. It'll also have the variable to turn it on.

    https://kb.mediatemp…mediatemple.net/questions/793/

    What should I do?

  6. Kathryn
    Automattic Happiness Engineer
    Posted 11 months ago #

    Hi there, I won't be able to help you modify your server settings as that's outside the realm of theme support.

    If your host won't help you with this and you're not comfortable following their guide, you may want to hire a server person to assist you. Good luck!

  7. mt-Drew
    Member
    Posted 11 months ago #

    Hi there guanmu,

    Sorry I am a little late here but the information you have received so far is correct. Unfortunately, we're unable to make changes to your php.ini file on your behalf, nor set up WordPress plugins for you as it falls outside the scope of (mt) Media Temple support. I would echo Kathryn's suggestion on possibly hiring a server admin or someone familiar with this practice to help you. On the other hand, if you would rather save yourself the search, we do offer a special paid service call CloudTech and one of the things they can do for you is set up and configure WordPress Plugins. More information on that is provided at the link below:

    http://mediatemple.net/cloudtech/ondemand/#service_4_anchor

    If you have any other questions for us, we're available 24/7 on Twitter: @MediaTempleHelp

    Drew J
    [ Signature moderated. ]

  8. Kathryn
    Automattic Happiness Engineer
    Posted 11 months ago #

    Hi Drew, thanks for chiming in! I'm just wondering how a plugin would help this user with the editing of their php.ini file? It isn't something I'd mentioned so I'm just wondering where that came from.

    one of the things they can do for you is set up and configure WordPress Plugins

  9. mt-Drew
    Member
    Posted 11 months ago #

    Hi there Kathryn. My apologies, to be perfectly honest, I was not familiar with Ryu and assumed it was a WordPress Plugin, I see now that is is a theme. Either way, the suggestion I made above still applies. Sorry about that :)

    If you have any other questions for us, we're available 24/7 on Twitter: @MediaTempleHelp

    Drew J

  10. Kathryn
    Automattic Happiness Engineer
    Posted 11 months ago #

    Thanks for clarifying, Drew. :-)

  11. bluhmpa
    Member
    Posted 10 months ago #

    Help anyone...

    I too want to use the Ryu theme and I've done all of the above, but it's not working. Help... anyone...

  12. guanmu
    Member
    Posted 10 months ago #

    Hi Bluhmpa,

    It's easy.

    connect your ftp, find the file php.ini in folder "etc".

    download php.ini and edit it with some coding app ( I am using Sublime Text 2)

    add

    allow_url_fopen = 1

    at the bottom of php.ini

    save and upload via ftp

    done.

  13. bluhmpa
    Member
    Posted 10 months ago #

    Yup, I've done that 3 times now! It's not working for me...

  14. Andrew
    Forum Moderator
    Posted 10 months ago #

    Then you are not experiencing the same issue. Can you create a thread regarding your issue Bluhmpa?

  15. bluhmpa
    Member
    Posted 10 months ago #

    Hi Andrew,
    Okay, I started a new thread. Hopefully someone can help me:
    http://wordpress.org/support/topic/ryu-theme-formatting-not-working/

Reply

You must log in to post.

About this Theme

About this Topic

Tags