WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Form not working with 3.5 (15 posts)

  1. tnguyen14
    Member
    Posted 1 year ago #

    I used the form builder to add a form to a page, and got this error in the editor:

    Notice: Trying to get property of non-object in /path/to/my/wordpress/directory/wp-includes/post-template.php on line 29

    http://wordpress.org/extend/plugins/jetpack/

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Could you try to reinstall WordPress 3.5, to make sure it is properly updated? Some files might have been corrupted when you updated to 3.5.

    Let me know if that helps.

  3. tnguyen14
    Member
    Posted 1 year ago #

    Hi, thanks for the reply. I just did the reinstall and still have the problem.

  4. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Could you give me your site URL, so I can investigate further?

    If you prefer it to remain private, you can contact us via this contact form:
    http://en.support.wordpress.com/contact/?jetpack=needs-service

  5. tnguyen14
    Member
    Posted 1 year ago #

    Hi thanks so much. My site URL is http://tridnguyen.com

  6. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Thanks. Could you try to deactivate all your other active plugins one by one, and see if one of them causes the problem?

  7. tnguyen14
    Member
    Posted 1 year ago #

    Thanks. I tried to deactivate all of the other plugins one by one, and I still get this error:

    Notice: Trying to get property of non-object in /home/tridn/public_html/main/wp-includes/post-template.php on line 29

  8. Mydailyrants
    Member
    Posted 1 year ago #

    Hey i'm having a problem with the form as well I can post it but it looks distorted, i'm running the P2 theme I think the css is messed up here is the link http://mydailyrants.com/contact-us/

    I have tried a reinstall, I have deactivated all add-ons, however the comment field is messed up

  9. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @tnguyen14 Could you check if WP_DEBUG is set to false in your wp-config.php file?

    @Mydailyrants Your problem seems to be different. Could you start a new thread about the issue?

  10. tnguyen14
    Member
    Posted 1 year ago #

    Thanks Jeremy. WP_DEBUG is in fact set to true? Would that be the reason for this error?

  11. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @tnguyen14 Thank you! I was able to reproduce the issue as well.

    I have reported the issue to our developers, and we will work on a fix as soon as possible.

  12. tnguyen14
    Member
    Posted 1 year ago #

    Thanks! Looking forward to the fix!

  13. Christopher Finke
    Design Engineer at Automattic
    Plugin Author

    Posted 1 year ago #

    This bug has been fixed for Jetpack 2.1. (See http://plugins.trac.wordpress.org/changeset/647531)

  14. Christopher Finke
    Design Engineer at Automattic
    Plugin Author

    Posted 1 year ago #

    (Marking as resolved.)

  15. tnguyen14
    Member
    Posted 1 year ago #

    Thanks for the awesomely quick response! You guys rock!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.