WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7 Multi-Step Forms
Form not redirecting to next page (4 posts)

  1. freshlinx
    Member
    Posted 10 months ago #

    Hi

    I have set up the 2 part form on my WordPress site which is currently on my MAMP-based development server so the address is localhost/sellyourhouseswiftly.dev

    I have set put the second form on a separate page (address: http://localhost/sellyourhouseswiftly.dev/enquiry-step-2/).

    I have put [hidden step "1-2"] in first contact form which is on homepage, and [hidden step "2-2"] in the second contact form.

    In additional settings I have put: on_sent_ok: "location.replace('localhost/sellyourhouseswiftly.dev/enquiry-step-2/';")

    However, the first form does not redirect to second page on submitting form... Is this because it is on a dev server or have I done something wrong?

    Would appreciate some advice.

    Thanks :)

    http://wordpress.org/plugins/contact-form-7-multi-step-module/

  2. webheadllc
    Member
    Plugin Author

    Posted 10 months ago #

    It works on my local server running MAMP. You may want to check firebug for any javascript errors. Also in the additional settings you may want to add "http://" to your localhost address. Not sure if it matters.

  3. freshlinx
    Member
    Posted 10 months ago #

    Thanks - I got it working in the end - had a typo on the redirection line in Additional Settings. So now it reaches the second page of the form. But now when I enter all the details on second form and click Submit button...nothing happens. No Ajax confirmation message and no email is sent ( I have [hidden step "2-2"] in the form and have completed all the necessary fields in the email section of contact form. Any ideas why the second form is not sending anything?

    Thanks :)

  4. freshlinx
    Member
    Posted 10 months ago #

    OK sorry - just realised that SMTP will not be set up by default on MAMP server! I have put demo_mode:on into Additional Settings and it "goes through the motions!".

    I have now put the site up on my hosting, and when I submit the first form page, it redirects to the correct address (in the url bar) but I get no new form just a message saying: "Please fill out the form on the previous page" even though the form has been completed...

    On development server, the form redirects fine! Any ideas?

    Here is the URL if that helps!
    http://sellyourhouseswiftly.co.uk.217-199-161-218.freshlinxwebdesign.com/

    Many thanks!

Reply

You must log in to post.

About this Plugin

About this Topic