WordPress.org

Ready to get started?Download WordPress

Forums

Gravitate Encryption
Form data is blank on Entries page using A-Symmetric Encryption (5 posts)

  1. Moondrop
    Member
    Posted 10 months ago #

    Hello,

    When using A-Symmetric Encryption, the entries listing on the Entries page (page=gf_entries) are blank. For example, the column will be First Name, and the info under it will be blank. However, clicking View on the blank entry will display the all the entry data properly (the individual view of an entry).

    When I run the encryption test in the settings page (A-Symmetric) everything is working properly.

    I have also tried Symmetric Encryption, and the blank Entries page issue does not occur.

    Any help would be much appreciated.

    http://wordpress.org/plugins/gravitate-encryption/

  2. Gravitate
    Member
    Plugin Author

    Posted 9 months ago #

    Hi Moondrop,
    Sorry for the delay. I have been out of work for ahile do to injuries.

    Anyways, I conffirmed your issue. This is caused by Gravity Forms returning two different values. Short Detials for the Listing Page and Full Detials on the Detailed Page. Since they are returning the Short Details on the Listing page the encrypted data is passed to the Decryption function without all of the characters need to decrypt it properly.

    The good news is I will have an update out shortly that will bypass this issue.

    Sorry that we didn't catch this sooner, but the issue depends on the size of the A-Symmetric encryption and that may vary from server to server.

  3. Gravitate
    Member
    Plugin Author

    Posted 9 months ago #

    Ok, I updated the Plug to version 1.0.4

    Keep in mind that I disabled the Auto Update for this plugin.
    I want to make sure that people Back-Up their data first and also know what they are doing.

    So you have to manually update the plugin.
    Just download the latest version and FTP in to your server and overwrite the files in the plugin directory.

    Let me know if you need help.

  4. Moondrop
    Member
    Posted 8 months ago #

    Hi Gravitate, sorry to hear about your injuries and thanks for the reply.

    I just tested out version 1.0.4 (using A-Symmetric), and some fields still remain blank on the Entries page, and other do not. As far as server setup goes, I am testing this locally with MAMP ver. 2.1.1.

    Below is a screenshot of what displays blank, with A-Symmetric saved in the settings. Sorry about the long width, you will need to download the png.

    Please note that I did not upload a 'Post image' or set a 'Hidden Field', so those are blank on purpose.

    https://www.dropbox.com/s/h95falxjz6jt2fn/gravitateEncrypt-entries.png?m

    The screenshot shows a comparison of Symmetric and A-Symmetric entries.

    Thanks again for your help.

  5. Gravitate
    Member
    Plugin Author

    Posted 8 months ago #

    Ok, It seems like the fields that are not shown are special Gravity Forms fields. So the formatting differences maybe causing the issue. I will try and replicate the issue and get back to you soon.
    If you don't see a reply soon, then please hit me up again.

    Thanks

Reply

You must log in to post.

About this Plugin

About this Topic