WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
Form checkbox and radio buttons not showing (2 posts)

  1. Stacy (non coder)
    Member
    Posted 8 months ago #

    I have the latest woo . Used a woo theme (mystile) and edited style.css to add radio and checkbox , played with changing the margin. Added it to the custom.css Nothing. There's no woocmommerce.css.

    /* Webkit browsers add a 2px margin outside the chrome of form elements */
    button,
    input,
    select,
    checkbox,
    radio,
    textarea {
      margin: 0;
    
    voilet.css says /* Hides the default checkbox style */  , tried removing this. 
    
    The checkbox seems like it should show properly.
    }
    input[type="checkbox"]:checked:before {
      content: '.';
    }
    input[type="checkbox"]:hover:before {
      background: rgba(255, 255, 255, 0.3);

    Tried changing float right to float left here

    .ginput_container .gfield_checkbox input,
    .ginput_container .gfield_radio input {
      float right;

    Any pointers?
    thanks

    http://www.urlgone.com/8ebafa/

    http://wordpress.org/plugins/woocommerce/

  2. MitzuWorks
    Member
    Posted 3 weeks ago #

    Hi Stacy!

    I ran into the same problem today and found a solution. Thought I'd would share it with you in case you're still looking for a solution.

    In your custom.css paste the following code:

    input[type="checkbox"] {
    -webkit-appearance: checkbox;
    }

    In the default css this reads "none" instead of "checkbox", hence nothing is displayed in webkit browsers ;-)

    Hope this helps,

    Ruud Denis
    MitzuWorks

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.