WordPress.org

Ready to get started?Download WordPress

Forums

Forever
[resolved] forever tags at top and bottom of content (10 posts)

  1. technobuddha
    Member
    Posted 9 months ago #

    Hi all, I just can't figure out where to find the extra <p></p> tags located at the top and bottom of the content page. I'm using google chrome, and I see that they are there, with no content. why and how to find them / get rid of them?

  2. technobuddha
    Member
    Posted 9 months ago #

    I've tried this:

    wpautop control, which doesn't work,

    and this:

    remove_filter( 'the_content', 'wpautop' );

    which does remove the top, BUT, it creates a huge gap at the bottom content and the footer!

    the website is: http://waxedwaxbar.pplsnet.com/

    I've taken out the filter for now

  3. technobuddha
    Member
    Posted 9 months ago #

    i realised, that i had to hard code in the #main to be height 500px. so its working now with the function...

  4. technobuddha
    Member
    Posted 9 months ago #

    ok, so its not resolved actually.
    When I put in the child function:

    remove_filter( 'the_content', 'wpautop' );
    and hard coded the #main height, things looked great.
    BUT, all of the content won't keep
    or <p> tags at all in the editor, so all I get is a continuous line! not good.

    So I'm still stuck in trying to figure out how to get rid of the top and bottom empty <p></p> tags from the content area...

  5. Hi there, the only paragraph tag on your homepage that I see in your source is here:

    <p><code><div class="slideshow_container slideshow_container_style-light" style="height: 480px; " data-session-id="0" data-style-name="style-light" data-style-version="2.2.19">

    You might try turning off your slideshow plugin (Slideshow Jquery Image Gallery, right?) and see if the stray tag goes away.

  6. technobuddha
    Member
    Posted 9 months ago #

    sorry for taking so long to respond.
    I've been trying to find the best way to describe what's going on, since I don't consider myself a PHP person, just a systems admin.

    here is an image to help explain

    Ok, so I disabled the "slider", aka the slideshow_container, to see if that was the problem. Nope. When I have an empty page, there is no <p></p> at all. In the image on top, you will see that I then decided to put in the letter X, and low and behold, the X went inside the <p></p>

    so that's ok. Fine, I can live with having the main page having an "extra" <p> when there is no letters. Its a shortcode.
    What's really bugging me, is the footer issue.

    you can see on the image at the bottom, there is a LOT of extra space betwen the bottom of the div id="content role="main", and the top of the footer, and I just can't figure out what's causing it.

    any help would be appreciated.

  7. WPyogi
    Volunteer Moderator
    Posted 9 months ago #

    Looks like that's the margin here:

    .hentry {
        margin: 0 0 3.23em;
        position: relative;
    }
  8. technobuddha
    Member
    Posted 9 months ago #

    WOOHOO!

    Thank you!!!!

    now to go look up .hentry!

    thank you very much, and have a lovely weekend!!!!

  9. WPyogi
    Volunteer Moderator
    Posted 9 months ago #

    You only need to COPY that bit to your child theme and change the margin.

  10. technobuddha
    Member
    Posted 9 months ago #

    yep! perfect!
    thank you!

Reply

You must log in to post.

About this Theme

About this Topic