WordPress.org

Ready to get started?Download WordPress

Forums

Forcing line breaks and spaces (9 posts)

  1. mkirkwag
    Member
    Posted 3 years ago #

    I keep forgetting that the visual editor isn't WYSIWYG :-(

    I add paragraphs (enter) and often that doesn't work - even if I've pasted it in via the Word paste choice. I look at the html view and see no difference between the times it works and the times it doesn't. I often enter <break></break> to create some white space, but this is obviously incorrect, because if I ever, ever even open that page again in the visual editor, the breaks all disappear and I have to start all over. Additionally, it doesn't always work. AND when I view source, it doesn't read that way. Now for example, a section that I added breaks to reads:
    `<break></break>
    <break></break></p>
    <h2>Welcome to the Tribe of Admins!</h2>
    <p><break></break></p>'
    OK, that's not right.

    Can you tell me what the correct code to create to create blank lines with xhtml is?

    Thanks for your help!

    site is http://tribeofadmins.com

  2. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    <br class="clear" /> works for me

  3. mkirkwag
    Member
    Posted 3 years ago #

    That seems to work (thanks!!), though it creates a very large space. I thought the definition of the amount of space would be in my template, but I can't find anything for either br or clear in the theme at all. Any idea how I control that?

  4. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    well, you can change the word clear to anything else really, and add it to your css. I believe line-height is the propert for br classes? I'm kind of spacing on it right now

    like <br class="small" />

    css would be:

    br.small {
        line-height: 3px;
    }
  5. inspiritor
    Member
    Posted 3 years ago #

    Hey guys!

    Well none of those things are working for me!
    I get line breaks occuring randomly. I can fix them in the visual editor, or the html editor and they look fine when I preview the post. However, when I go to the view site it is scrambled again!!

    Help!!

    Thanks

    Charlie

  6. mkirkwag
    Member
    Posted 3 years ago #

    Annoying, isn't it? One thing - do it in the html editor, then close out of it. Don't look at the page in visual editor - that changes it back to the scramble. *Really* irritating.
    It seems to me that there must be a standard code for a line break!

  7. inspiritor
    Member
    Posted 3 years ago #

    Thanks! I'll give it a try.

    Does that mean that if I paste a word document into
    my post that I should copy it into the html editor and never into the visual editor?

    You would think with hundreds of thousands (or more) of people
    using wordpress, that this would be dealt with. It is really mindboggling. After all, who care if there are ten thousand plugins and widgets when one of the most basic elements - making a post - is so confusing.

  8. esmi
    Forum Moderator
    Posted 3 years ago #

    Does that mean that if I paste a word document into
    my post that I should copy it into the html editor and never into the visual editor?

    Don't paste content from Microsoft Word into WordPress as the pasted text will also contain Word's own formatting. Sooner or later, this formatting will stop your pages from being displayed correctly (if at all) in Internet Explorer. If you cannot possibly manage without Word, paste your text into NotePad (or another text editor) first, then copy from NotePad into WordPress.

    Or use the inbuilt Paste from Word option in the Visual Editor. Or Windows LiveWriter.

  9. mkirkwag
    Member
    Posted 3 years ago #

    I'm sure esmi is right and that's probably been the cause of some problems for both of us. Whatever you choose to do in that regard - yes, you can paste it into the visual editor. You can work on it there...it's just that the *last* thing you do seems to have to be any changes you make in the html editor, at least with this white space issue. If you finally get your spaces right in the html editor then, at some later date, open the page in the visual editor, the changes you made in the html editor will disappear and you'll have to redo them. Very frustrating! I don't think it's true for standard changes you might make to the html, but it seems that creating a double space is non-standard to WP.

Topic Closed

This topic has been closed to new replies.

About this Topic