WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
Force SSL Exclusively Redirect Loop (5 posts)

  1. birdwell
    Member
    Posted 6 months ago #

    I'm using the latest version of WordPress HTTPS with WP v3.8.

    I only have one other plugin running that's a map plugin, has nothing to do with security/SSL/redirects.

    I have my install and site url set to http://
    I have FORCE_SSL_ADMIN set in my wp-config.php
    My htaccess just has the normal WordPress rewrite conditions, nothing else related to security/SSL/redirects.

    When I activate Force SSL Exclusively in the plugin settings, it causes an http/https redirect loop on the page that I set to secure.

    Any ideas? I'll try to give more specific information if you ask for it. I'm really not sure what else could be causing it. I have found some old posts from a year or so ago, about a similar bug in the plugin causing the same issue, but I haven't seen anyone else posting with this problem.

    Thanks for any insight.

    https://wordpress.org/plugins/wordpress-https/

  2. birdwell
    Member
    Posted 6 months ago #

    I'm still having this issue and guess I'm the only one experiencing it then. Any ideas as to what I may be overlooking that would be causing the redirect loop?

  3. fktc
    Member
    Posted 6 months ago #

    Hi,

    have you checked your theme's functions.php for any function that might cause this? Have you tried using a default theme (e.g. twentyfourteen)?

    fktc

  4. birdwell
    Member
    Posted 6 months ago #

    I did check functions.php and didn't see anything. I went ahead and double checked it when you posted. I'm dealing with a live site so I don't have the liberty to just change themes on the fly like that... it was a custom theme created by someone before me and I'm coming in behind trying to make changes/updates for the client. For the most part it's been pretty straight forward. This redirect issue is the first thing that has thrown me for a loop (duh dun tsss).

    But seriously, I've checked every place I could thing to check with no luck yet. I wish there was an easy way to identify where the loop is hitting and being generated from.

  5. Andrew Byrd
    Member
    Posted 6 months ago #

    I had a similar issue with my SSL pages having redirect loops after auto-updating to WordPress 3.8.1. As fktc suggested, previously I had made changes to my functions.php file, specifically modifying is_ssl() to check if HTTP_FRONT_END_HTTPS was set to 'on' and that change had been reverted. Updating the code so it correctly detected if SSL resolved the redirect loops.

Reply

You must log in to post.

About this Plugin

About this Topic