WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Force non-SSL in WordPress (5 posts)

  1. JohnnyBravo82
    Member
    Posted 5 months ago #

    Hi guys,

    Ok - so this is odd - actually backwards!

    I've just migrated between hosts. On my old hosting site I was running an SSL. I haven't been able to apply this SSL with my new host yet, so the site is no longer running in https://

    I've made the necessary changes from the general settings page so the site loads absolutely fine from http:// rather than https://, however all my images are still loading from https:// which means in all browsers other than Chrome they won't show.

    Images inserted manually via the media uploader show, but all automatic images (such as header images or icons with shortcodes) won't show atall, as they're all trying to show from an https:// source.

    I'm wondering if there is anyway I can force the images to load from http:// and not https:// as they use to? I've tried refreshing permalinks and can't find any obvious settings in config.php.

    Any ideas anyone? Helps is greatly appreciated. Cheers :)

  2. JohnnyBravo82
    Member
    Posted 5 months ago #

    Looks like I'm going to have to buy another SSL then and revert to https:// then?

    Just surprised this isn't something that's been encountered by somebody else to date?

  3. Dave Naylor
    Member
    Posted 5 months ago #

    You could try the search and replace plugin. Replace all instances of https://your.domain with http://your.domain

  4. JohnnyBravo82
    Member
    Posted 5 months ago #

    Thanks - I'll try that and let you know what happens :)

  5. JohnnyBravo82
    Member
    Posted 5 months ago #

    WPRanger you're a star - worked like a charm. The only noticeable downside was that it seemed to wipe some changes I've made to the wp-bar via an WPMU plugin - but that can easily be re-applied.

    Literally just typed search for; https:// - change to http:// and clicked Go - it did the rest brilliantly.

    Great suggestion - thank you. :)

Reply

You must log in to post.

About this Topic