WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Force 1&1 to use PHP5, pages now broken (5 posts)

  1. passionbeer
    Member
    Posted 4 years ago #

    I added an .htaccess file to my site to force 1&1 to use PHP5. They are notorious for serving PHP4 by default. Anyway, I run a phpinfo() and it shows it's now running PHP5 but all my permanent links are broken.

    I can pull the main page fine but any page off their servers a 404 error.

    Ideas? Please help!

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Did you replace the WordPress .htaccess file or add to it? Are you using pretty permalinks? If so, try resetting your custom permalinks back to the default setting. If that works, then set your custom permalink structure back up again.

  3. passionbeer
    Member
    Posted 4 years ago #

    Esmi, I cannot thank you enough!

    I was actually replacing the original WordPress .htaccess file. Adding the code to the original WordPress .htaccess file seems to be working fine! My server is reporting PHP5 and all my links work!

    Thanks a million, you're a life saver :)

  4. Rudeseal
    Member
    Posted 3 years ago #

    what code did you add to the .htaccess file for 1and1 php5??

  5. simoncmason
    Member
    Posted 3 years ago #

    Hi,

    This is the code you want:

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    Enjoy

    Simon

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags