WordPress.org

Ready to get started?Download WordPress

Forums

Forbidden - Just migrated to AWS (15 posts)

  1. amplicity
    Member
    Posted 12 months ago #

    Hi, I just migrated my site to AWS using bitnami, and this guide > http://www.agileweboperations.com/migrate-your-wordpress-blog-to-a-bitnami-ec2-instance

    The AMI I used is located here and the ID is ami-471e6d2e.

    I followed the instructions to a T, but my whole blog is labeled as forbidden. I can't access the wp-admin page either. This happened AFTER I migrated my blog over (htdocs and mysql backup) and then followed the rest of the instructions on that guide I referenced above. I am not sure where to go from here, could anyone provide some light on what I should try fixing?

  2. amplicity
    Member
    Posted 12 months ago #

    my blog is located at http://www.bangtothebeat.com

  3. You may want to check out http://community.bitnami.com/. Are all your permissions and hosts configured correctly?

  4. amplicity
    Member
    Posted 12 months ago #

    that's what i was hoping to find out :)

    my wp-config.php points to:
    db: bitnami_wordpress
    user: root
    pass: bitnami

    my httpd.conf file modifications:
    http://image.bayimg.com/2652b616cf612cdc1c3fcca36d668f51095ea469.jpg

    my httpd-vhosts.conf file modifications:
    http://image.bayimg.com/9dc2302ad93b47e1482bcffcecb887b920a88e7b.jpg

    my .htaccess file modifications:
    http://image.bayimg.com/59d5cb335988bd9dbe5a8158ee108b4bcd07c47a.jpg

    I ran this on the db:

    mysql -uroot -p bitnami_wordpress
    mysql> update wp_options set option_value = 'http://www.bangtothebeat.com' where option_name in ('siteurl', 'home');
    Query OK, 2 rows affected (0.00 sec)

    I also deleted the /opt/bitnami/updateip file

    Anyone that can help would be greatly appreciated. I am going to post this on community.bitnami.com as well and link to the post, so that anyone else with this problem may properly find the answer. Thanks!

  5. amplicity
    Member
    Posted 12 months ago #

  6. amplicity
    Member
    Posted 12 months ago #

    image links should all work now i just double checked! Please let me know if you can't see them.

  7. SGDLucas
    Member
    Posted 12 months ago #

    1.) Those bayimg.com links are still giving "403 - Forbidden" errors.

    2.) Check .htaccess / try renaming it

    3.) Check file permissions. There's a good tip at http://codex.wordpress.org/Hardening_WordPress#File_Permissions to do the following:

    find /path/to/your/wordpress/install/ -type d -exec chmod 755 {} \;
    find /path/to/your/wordpress/install/ -type f -exec chmod 644 {} \;

    4.) Check the apache error log

  8. amplicity
    Member
    Posted 12 months ago #

    I reuploaded all the images on imageshack, hopefully everyone will be able to view these

    httpd.conf modifications:
    http://imageshack.us/photo/my-images/38/njw4.jpg/

    my httpd-vhosts.conf modifications:
    http://imageshack.us/photo/my-images/542/o1pk.jpg/

    my .htaccess file modifications:
    http://imageshack.us/photo/my-images/703/ejc0.jpg/

    @SGDLucas, the .htaccess file instructions were confusing to me when setting up, could you check the image I posted and see if what I wrote was correct? I wasn't sure where to write the new details so I did my best to guess, but I'm not sure if it's right or not. I'm going to try what you said now.

  9. SGDLucas
    Member
    Posted 12 months ago #

    Method 1.) Delete or rename '.htaccess'

    Method 2.) Replace the content of '.htaccess' with the default WP htaccess code here: http://codex.wordpress.org/Using_Permalinks#Creating_and_editing_.28.htaccess.29

  10. Gritcore
    Member
    Posted 12 months ago #

    Did you try the suggestion above?

    find /path/to/your/wordpress/install/ -type d -exec chmod 755 {} \;
    find /path/to/your/wordpress/install/ -type f -exec chmod 644 {} \;

    Seems like you have a file permission issue...

  11. amplicity
    Member
    Posted 12 months ago #

    I have tried:

    Deleting .htaccess (no result)
    Replacing .htaccess with information provided by SGDLucas (no result)
    Redid all file permissions using: (no result)

    find /path/to/your/wordpress/install/ -type d -exec chmod 755 {} \;
    find /path/to/your/wordpress/install/ -type f -exec chmod 644 {} \;

    I'm at a loss for ideas, I'm not sure where to go from here.

    Here is my error log:

    [Fri Aug 02 14:15:19.013515 2013] [ssl:warn] [pid 10864] AH01909: RSA certificate configured for wordpress.example.com:443 does NOT include an ID which matches the server name
    [Fri Aug 02 14:15:19.013867 2013] [ssl:warn] [pid 10864] AH01909: RSA certificate configured for localhost:443 does NOT include an ID which matches the server name
    [Fri Aug 02 14:15:19.013906 2013] [ssl:warn] [pid 10864] AH02292: Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
    [Fri Aug 02 14:15:19.219743 2013] [ssl:warn] [pid 10865] AH01909: RSA certificate configured for wordpress.example.com:443 does NOT include an ID which matches the server name
    [Fri Aug 02 14:15:19.220031 2013] [ssl:warn] [pid 10865] AH01909: RSA certificate configured for localhost:443 does NOT include an ID which matches the server name
    [Fri Aug 02 14:15:19.220067 2013] [ssl:warn] [pid 10865] AH02292: Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
    [Fri Aug 02 14:15:19.220161 2013] [lbmethod_heartbeat:notice] [pid 10865] AH02282: No slotmem from mod_heartmonitor
    [Fri Aug 02 14:15:19.260087 2013] [mpm_prefork:notice] [pid 10865] AH00163: Apache/2.4.4 (Unix) OpenSSL/1.0.1e PHP/5.4.16 configured -- resuming normal operations
    [Fri Aug 02 14:15:19.260178 2013] [core:notice] [pid 10865] AH00094: Command line: '/opt/bitnami/apache2/bin/httpd -f /opt/bitnami/apache2/conf/httpd.conf'
    [Fri Aug 02 14:15:29.271089 2013] [mpm_prefork:error] [pid 10865] AH00161: server reached MaxRequestWorkers setting, consider raising the MaxRequestWorkers setting
    [Fri Aug 02 14:19:19.191511 2013] [mpm_prefork:notice] [pid 10865] AH00169: caught SIGTERM, shutting down
    [Fri Aug 02 14:19:23.468736 2013] [ssl:warn] [pid 10902] AH01909: RSA certificate configured for wordpress.example.com:443 does NOT include an ID which matches the server name
    [Fri Aug 02 14:19:23.469082 2013] [ssl:warn] [pid 10902] AH01909: RSA certificate configured for localhost:443 does NOT include an ID which matches the server name
    [Fri Aug 02 14:19:23.469121 2013] [ssl:warn] [pid 10902] AH02292: Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
    [Fri Aug 02 14:19:23.621857 2013] [ssl:warn] [pid 10903] AH01909: RSA certificate configured for wordpress.example.com:443 does NOT include an ID which matches the server name
    [Fri Aug 02 14:19:23.622118 2013] [ssl:warn] [pid 10903] AH01909: RSA certificate configured for localhost:443 does NOT include an ID which matches the server name
    [Fri Aug 02 14:19:23.622154 2013] [ssl:warn] [pid 10903] AH02292: Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
    [Fri Aug 02 14:19:23.622234 2013] [lbmethod_heartbeat:notice] [pid 10903] AH02282: No slotmem from mod_heartmonitor
    [Fri Aug 02 14:19:23.661640 2013] [mpm_prefork:notice] [pid 10903] AH00163: Apache/2.4.4 (Unix) OpenSSL/1.0.1e PHP/5.4.16 configured -- resuming normal operations
    [Fri Aug 02 14:19:23.661720 2013] [core:notice] [pid 10903] AH00094: Command line: '/opt/bitnami/apache2/bin/httpd -f /opt/bitnami/apache2/conf/httpd.conf'
    [Fri Aug 02 14:19:32.671296 2013] [mpm_prefork:error] [pid 10903] AH00161: server reached MaxRequestWorkers setting, consider raising the MaxRequestWorkers setting
  12. SGDLucas
    Member
    Posted 12 months ago #

    Ok, then work from the other direction. Can you get a static HTML page to display? No WordPress (no PHP), just HTML. That should tell you whether you have apache correctly configured.

  13. DeeJay176
    Member
    Posted 12 months ago #

    Hi Friend - we are on AWS with wordpress and about to do a 3.6 upgrade.

    AWS is very WordPress friendly however I've not used the bitnami image. We created our own LAMP server configurations.

    I noticed several things in your apache log:

    You are getting SSL warnings - you need to check your certificate setup
    You are getting mpm_prefork errors - this is an apache configuration issue and you may need to check the settings in the httpd.conf file. It appears as though you may not have enough memory or there's another configuration out of place.

    What size EC2 did you choose? Where is the database, is it local to EC2 or is it on RDS?

  14. amplicity
    Member
    Posted 12 months ago #

    Hey DeeJay176,

    I noticed the errors and warnings, however, I also have this posted on the bitnami community and it doesn't seem to be of concern to the most recent poster. You can check that out here. He mentioned they were warnings, but I do notice that I'm getting mpm_prefork errors, could this cause a forbidden?

    I am leaning more towards what the poster on the bitnami forum was saying. He mentioned something about the way the .htaccess files are handled with bitnami, leading him to believe that my updates to my .htaccess file for wordpress are not being registered in the application. The document he referenced is here, but I am still a little confused on how to setup the document he references (/apps/wordpress/conf/htaccess.conf).

    Obviously this seems bitnami-specific, but is there anyway to have bitnami redraw my .htaccess file? I think that is the issue, rather than server issues, as I am getting forbidden rather than a 500 server error, but who knows. i'm very new to server tech, and especially AWS.

    To answer your questions, I chose a micro instance, the database is local to EC2 (i believe, I have no remote database setup).

  15. amplicity
    Member
    Posted 11 months ago #

    got rid of bitnami, installed amazon linux ami, and followed this tutorial. http://coenraets.org/blog/2012/01/setting-up-wordpress-on-amazon-ec2-in-5-minutes/

    From there, I..

    1. Replaced the default "blog" with my blog backup by simply copying and pasting via SFTP
    2. set the chmod 777 for .htaccess (so wordpress can write to it when needed)
    3. mysql -uroot -ppassword blog < mysqldump.sql

Reply

You must log in to post.

About this Topic