WordPress.org

Ready to get started?Download WordPress

Forums

Forbidden Access (4 posts)

  1. AmericanBrandy
    Member
    Posted 7 years ago #

    I found my wp-powered blog hijacked once again so I did what I did the last time to fix it...that is posted here:
    http://wordpress.org/support/topic/91313?replies=4

    Then I tried to follow a recommendation to change the CHMOD access BUT now I get this, when I try to log into my wordpress to post an entry:
    Forbidden
    You don't have permission to access /journal/wp-login.php on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/1.3.37 Server at http://www.americanbrandy.net Port 80

    After further tampering I am now getting this same message weven when I try to view my wp journal.
    (www.americanbrandy.net/journal)
    Any idea what I did wrong?
    Thanks in advance
    Brandy

  2. whooami
    Member
    Posted 7 years ago #

    correct chmod:

    directories: 755
    files: 644

    that other post told you what not to use, but didnt tell you what you should have instead :), so.. since you didnt say exactly what you did do, i can only suggest the proper permissions.

  3. AmericanBrandy
    Member
    Posted 7 years ago #

    My ftp program sets the permissions dependent on what options I check and I am getting 744, not 755.
    I would love to tell you exactly what I did but I have NO clue. :(
    All I remember is trying to change the chmod settings first on the one file and then on the entire directory. Does that help? I am clueless and try to leave this kind of stuff alone when possible for just this reason but I wanted to avoid getting hijacked again.
    It's really frustrating, my husband is deployed overseas and plans to use my journal to keep up with me and the kids while he is away and I just can't figure this out. :(

  4. Piet
    Member
    Posted 7 years ago #

    Hi,

    I also have had many problems with CHMOD and most of the times also don't understand what's going on exactly.

    But I think I sorta figured it out now...

    First you CHMOD 755 the main directory where WordPress resides

    CHMOD in your ftp-program probably gives you a screen with 3 groups:
    User, Group, Other
    underneath each of them you probably see:
    Read, Write, Execute

    To CHMOD the directory WordPress resides in you tick on the following:

    User: Read, Write, Execute
    Group: Read, Execute
    Other: Read, Execute

    Then you go into the main directory and you select the 3 directories wp-admin, wp-content and wp-includes and you also CHMOD 755 them (exact same settings as above

    Then you select all files (so without the directories) and you perform a CHMOD 644 on them:
    User: Read, Write
    Groups: Read
    Other: Read

    This at least allows you to access your blog normally and enables you to write posts.

Topic Closed

This topic has been closed to new replies.

About this Topic