WordPress.org

Ready to get started?Download WordPress

Forums

fopen() Cron Error (7 posts)

  1. Michael Fields
    Themer
    Posted 3 years ago #

    I keep getting this error every once and a while on my local installation. I've never seen it on a live site. Maybe you could tell me why and if there's anything I can do to make it disappear.

    Warning: fopen(http://localhost/3.0/wp-cron.php?doing_wp_cron) [function.fopen]: failed to open stream: HTTP request failed! in C:\xampplite\htdocs\3.0\wp-includes\class-http.php on line 1045

    Thanks!
    -Mike

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    I get this at intervals on my local install too but I just ignore it and refresh the page. I think it's a Windows/PHP specific issue which (I assumed) was directly related to running WP inside a ported LAMP environment within Windows.

    Certainly nothing to worry about.

  3. Michael Fields
    Themer
    Posted 3 years ago #

    Thanks! Did you or anyone else ever find a workaround? It's glad to hear that this is not a big issue, but sometimes I will wait 8-10 seconds for the page to load and then this error will appear.Which is not a crisis but can be a bit annoying when constantly refreshing pages during development.

  4. NerdInProgress
    Member
    Posted 3 years ago #

    Is it possible that it is from some plugin that setup a cron and is now disabled?

    I have the same problem and I remember that when I'd tested Mailman, something to do with cron had come up.... it is uninstalled, but this message comes up with debug enabled. Is there a way to check why wordpress is doing the cron?

  5. Michael Fields
    Themer
    Posted 3 years ago #

    I was hacking around a bit this morning with the wp_remote_request() function which calls fopen(). I used a very simple request which sent my whole system spaz-out:

    $test = wp_remote_request( 'http://localhost/3.1/', array( 'topics' => 'ajax' ) );

    However, the function worked fine when accessing a true remote url:

    $test = wp_remote_request( 'http://wordpress.mfields.org/', array( 'topics' => 'ajax' ) );

    Is there anything that I need to configure in windows to stop this from happening? It happens rather frequently for me.

  6. Michael Fields
    Themer
    Posted 3 years ago #

    @ocean90 Thanks for posting a link to that ticket. Very informative. I no longer develop on a Windows machine. And have not noticed the errors since I switched.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.