WordPress.org

Ready to get started?Download WordPress

Forums

Zenphoto Gallery
fopen (6 posts)

  1. sojweb
    Member
    Posted 2 years ago #

    Thanks for the cool plugin. Seems like it has a lot of potential.

    After configuring the path in options, I get a message regarding fopen. I don't have fopen enabled on my server. Can you think of any ways to use curl instead?

    Many Thanks.

  2. Raphael
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks for your feedback!

    What happens if you comment out the fopen stuff zpg_check_json (line 550) and just return true? I use fopen only to check wether the address is valid, the actual data is retrieved by file_get_contents; maybe it does not use fopen?

    If not so, please open a ticket in the bugtracker and I will have a look when I work on the plugin again. I do not know to what extent curl can replace file_get_contents and wether it works for a proper superset of people, but maybe one can offer both?

  3. sojweb
    Member
    Posted 2 years ago #

    Hi Raphael,

    Thanks very much for your response. I really appreciate your help. I will make these changes and see if all works.

  4. sojweb
    Member
    Posted 2 years ago #

    Returning true didn't help, so I ended up enabling fopen on my server briefly to see if that would help. Still no luck, but at least now I know that it isn't an fopen issue. Seems like it might be a permissions issue on json.php inside of zenphoto.

    Thanks again for your help.

  5. Raphael
    Member
    Plugin Author

    Posted 2 years ago #

    You are very welcome!

    Maybe PHP offers more information if you enable debugging mode? (via wp-config.php)

    As for permission issues, just make sure that json.php has the same owner/group and permissions as other Zenphoto files you access.

  6. sojweb
    Member
    Posted 2 years ago #

    Hi Raphael,

    Debugging through wp-config didn't shed much light on the issue. I also double-checked my permissions for json.php. I'm still getting that same 'check configuration for details' message where the album should appear.

    My gallery is at: http://journalism.indiana.edu/apps/zenphoto/

    I'm attempting to call a sub album by like this:

    [zenalbum album=ErniePyle/BackHome]

    Do you have any other tips? I've been thinking about installing a wp pear debug or something similar.

    Thanks again for your time.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic