WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Footer links (7 posts)

  1. Thief_PL
    Member
    Posted 1 year ago #

    Hello my footer links don't work any i have no idea why, can someone look at the code and tell me what am i doing wrong? Thanks for your time!

    HTML

    <div class="footer">
    	<div class="footer-box-1">
    	  <ul style="margin-top:0px;">
    	    <li><a href="http://www.softwarereviewcenter.com/" title="Homepage">Home</a></li>
    	    <li><a href="http://www.softwarereviewcenter.com/about-us/" title="About Us">About Us</a></li>
    	    <li><a href="http://www.softwarereviewcenter.com/contact-us/" title="Contact Us">Contact Us</a></li>
    	    <li><a href="http://www.softwarereviewcenter.com/privacy-policy/" title="Privacy Policy">Privacy Policy</a></li>
          </ul>
    	</div>
      <div class="footer-box-2">Footer 2</div>
      <div class="footer-box-3"><strong>Follow us on...</strong></div>
    </div>

    CSS

    .footer {
    	width:890px;
    	margin-top:10px;
    	margin-bottom:10px;
    	margin-left:auto;
    	margin-right:auto;
    	color:#FFFFFF;
    }
    .footer-box-1 {
    	width:297px;
    	float:left;
    }
    .footer-box-2 {
    	width:297px;
    	float:left;
    }
    .footer-box-3 {
    	width:296px;
    	float:left;
    }
    .footer a:link, a:visited {
    	color:#FFFFFF;
    }
    .footer a:hover, {
    	text-decoration:none;
    	color:#FF0000;
    }
  2. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Can you post a link to the site where the problem exists?

  3. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    You are missing the closing </a></li> after "About Us" and missing a closing </ul> tag.

  4. Thief_PL
    Member
    Posted 1 year ago #

    Hi, i have updated the code but still no results. Any other ideas?

    Thanks

  5. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Without looking at the site, no way to say much else...

  6. Thief_PL
    Member
    Posted 1 year ago #

    [ Code moderated, for that many lines please use pastebin.com instead. ]

  7. Thief_PL
    Member
    Posted 1 year ago #

    Hi i have found the error! There was a unnecessary comma after

    a:hover,

    .footer a:hover, {
    	text-decoration:none;
    	color:#FF0000;
    }

    Solution

    .footer a:hover {
    	text-decoration:none;
    	color:#FF0000;
    }

    Now it works!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags