WordPress.org

Ready to get started?Download WordPress

Forums

Footer Disappeared in Firefox 1.5 & Opera 8.51 (6 posts)

  1. confablog
    Member
    Posted 8 years ago #

    http://www.confablog.com

    Ok, first, some prefatory remarks:

    - I know it isn't valid XHTML, I sacrificed that to try and get everything looking OK aesthetically. I literally just threw this site up last night and am a novice with CSS.

    Now, the footer isn't showing up in Firefox 1.5 and Opera 8.51 (In Firefox 1.07 everything is worse, and I've pretty much given up on that) Any idea what the problem may be?

    http://www.confablog.com

  2. Truth
    Member
    Posted 8 years ago #

    you don't have a closing body tag and html tag

    there's an empty #footer {} and #header {}

    Erm, I can't find where your footer image is though?

  3. Fix the validation, particularly the lack of the closing </body> and </html> tags, and it might be possible to see what else is wrong.

  4. confablog
    Member
    Posted 8 years ago #

    Ok, I added the body & html closing tags, I must've accidentally deleted them while editing the footer.php file.

    However, same problem

  5. Did you try revalidating?

    You have a <div> opened but not closed. That's the kind of thing browsers tend to dislike...

    The W3C validator thinks it may be your <div id="page"> that has lost its closing tag. Try adding that and see if things improve.

  6. confablog
    Member
    Posted 8 years ago #

    Seems to be same problem, I will try fixing all the invalidation

Topic Closed

This topic has been closed to new replies.

About this Topic