WordPress.org

Ready to get started?Download WordPress

Forums

Google Webfonts For Woo Framework
[resolved] Fonts not loading after plugin update (7 posts)

  1. mmtrav
    Member
    Posted 11 months ago #

    Hi guys,

    Just a note -- I had to resave my settings to get cached fonts back after an update of the plugin from 1.2.0 to 1.2.1. Bit of a mystery why it wasn't working...

    but after reading the github comments I eventually figured it out.

    Just in case anyone else has the same problem. Thanks for this plugin!

    http://wordpress.org/plugins/google-fonts-for-woo-framework/

  2. Jason Judge
    Member
    Plugin Author

    Posted 11 months ago #

    Thanks. I've noticed this too in one install. I'll a note to the installation instructions for people updating.

    I think I've working out why this is happening. Before 1.2, the font list was cached for 12 hours, and refreshed automatically. From 1.2 the fonts are cached indefinitely, and refreshed only by going into the settings page and saving. On upgrading, the cache will last for *up to* 12 hours, and then be flushed by WP, and then the Google Webfonts won't be accessible, at least until the admin saves the settings.

    What I should have done, on an upgrade to 1.2, is resave the cached fonts in WP without an expiry time.

    So apologies to anyone who have found the fonts suddenly disappear - just go into the settings page for this plugin and save, then they will be back.

  3. Jason Judge
    Member
    Plugin Author

    Posted 11 months ago #

    I won't close this issue until I've updated the docs (which I won't be able to do until next week).

  4. Jason Judge
    Member
    Plugin Author

    Posted 11 months ago #

    v1.2.2 should now fix this issue.

  5. Jason Judge
    Member
    Plugin Author

    Posted 11 months ago #

    Documents have been updated and fixes have been released. Not heard anything more, so I'll close this issue as fixed.

  6. KennyThemap
    Member
    Posted 6 months ago #

    Thanks for this work Jason. Much appreciated.

    For the benefit of we relative novices, should we be selecting a Server API key or a Browser API key or does it not matter?

  7. Jason Judge
    Member
    Plugin Author

    Posted 6 months ago #

    That's a good question, and I'm not entirely sure, mainly because I'm not sure what you are looking at.

    In the Google Developer's Console (https://cloud.google.com/console) I click on APIs and Auth->Credentials. Under there is a "Public API access" key that can be generated (button "create new key").

    Under the APIs tab, there is a list of services you want the key to access. Make sure "Web Fonts Developer API" is turned "ON". There are dozens of other APIs listed on that page, but only that one is needed for this plugin.

    As for the "browser" or "server" API key choice, I cannot see those terms used as a choice anywhere in the console, so you may be looking at something different to me.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags