WordPress.org

Ready to get started?Download WordPress

Forums

FontMeister - The Font Management Plugin
Font Squirrel/Caviar Dreams issue (10 posts)

  1. airjosh
    Member
    Posted 1 year ago #

    I am on wpengine.com and installed the plugin, downloaded Caviar Dreams and activated it. It shows up and I configured the selectors and everything seems fine except the font doesn't actually display and displays a generic serif font instead. The preview of the font shows fine using the magnifying glass, but the view of it in the Font Stack view even shows a generic serif font.

    http://wordpress.org/extend/plugins/fontmeister/

  2. webstantial
    Member
    Posted 12 months ago #

    I have had the same issues. This is an excellent custom font plugin with many very impressive features, but has two relatively simple bugs that prevent it from being useful:

    BUG #1

    In the source of the FontMeister Fonts tool, this incorrect path is found:
    http://project2a.webstantial.us/wp-content/uploads/fontmeister/Anagram/stylesheet.css

    The correct path to the associated stylsheet is:
    http://project2a.webstantial.us/wp-content/uploads/fontmeister/Anagram/web fonts/anagram_regular_macroman/stylesheet.css

    This error, of course, causes the sample text in the FontMeister Fonts tool to display in the default serif font, instead of the Anagram font.

    BUG #2

    The FontMeister Fonts do display as options in TinyMCE's [Font Family] dropdown, and do apply as:
    <p><span style="font-family: AnagramRegular;">…or something like this:</span></p>

    But there is no associated stylesheet is added the source of the sample page to define the font:
    http://project2a.webstantial.us/sample-page/

    Testing was done in the 2012 Theme, with permissions that work with over 100 other plugins.

    Please let me know if you can find the time to fix these bugs, as I would love to make this plugin one of my regular design tools.

    Thanx

    Kerry Power
    Webstantial Systems

  3. webstantial
    Member
    Posted 12 months ago #

    -- UPDATE --
    In regard to Bug #2 above, I changed the Font Sources/Font Squirrel setting to (*) Combined, and now I do get a stylesheet in the -head- of all posts/pages, but it has no content. Permissions were initially set to 755, and the file is replaced upon [Save], so I tested with 777 permissions just for kicks, but still got no content.

    I hope this helps you to resolve the display issue.

    Kerry Power
    Webstantial Systems

  4. kisshomaru
    Member
    Posted 11 months ago #

    I have the same issue.
    Also someone opened this thread where I wrote as well:
    http://aquoid.com/forum/viewtopic.php?f=4&t=24008&p=65645#p65645

    No answer yet...

  5. kisshomaru
    Member
    Posted 11 months ago #

    Oh, ok, I found the issue. It is a bug.
    I used the Chrome html inspector and modified the source stylesheet header file to start with https instead of http. I have SSL on the entire site.
    It worked on the manually modified page!!
    Now, I found the exact issue, can someone please tell me how to fix it in the plugin?
    I'll post this on the Aquoid thread as well.

  6. kisshomaru
    Member
    Posted 11 months ago #

    Created a different thread as it might be a different issue than what airjosh started here.

  7. kisshomaru
    Member
    Posted 11 months ago #

    After looking more into this, it is a different issue.
    Google fonts are working after I made that https replacement, but Squirrel will not. That seems to be a different issue.
    I modified the Upload Url Path of my site to start with https and links are made properly, but they still not link to the stylesheet.css in the proper folder.
    Good enough with google fonts for me...

  8. kisshomaru
    Member
    Posted 11 months ago #

    And the fix for this issue is to manually copy from the <upload folder >/fontmeister/<YourInstalledSquirrelFont>/web fonts/<Nextfolder>/ directly in <upload folder >/fontmeister/<YourInstalledSquirrelFont>/.
    Of course, you still need the Upload Url Path modified to use https if using SSL.

  9. Sayontan Sinha
    Member
    Plugin Author

    Posted 11 months ago #

    Kisshomaru,
    Thanks for the research on this - I will fix it as soon as I can free up some time.

    Sayontan.

  10. kisshomaru
    Member
    Posted 11 months ago #

    My pleasure, Sayontan.
    Another note on the Squirrel fonts issue:
    It is a bigger problem if the font has variants, each has it's own css...
    Best is to combine css (either in the css directly under the font folder , or use the combine feature) and manually reference each folder. Though a hassle if using many fonts, this works. Might have an issue in backend if using the second method.
    Looking a little at the code, Font Squirrel messed them up. You are retrieving info from their site via the font_squirrel_get_font_information function, but their folder structure and names (added macroman somth) changed and they don't match (not even in names).
    The best idea would be to create a ccs from scratch from each family in the font folder, by browsing all directories sub-trees and combining each of the found css also remembering the folder path. Easier said than done...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.