WordPress.org

Ready to get started?Download WordPress

Forums

Font mysteriously changes to illegible color - help (13 posts)

  1. mstess
    Member
    Posted 7 years ago #

    I am using Nine Shades of green and was trying to add the much-maligned AdSense search to the site. I don't know what happened, but my posts are suddenly in a white font and can't be seen at all.
    Being an ignorant newbie, I can't figure out how to change this back to black. It looks like it is set for black in the stylesheet.
    Please help.
    Thanks

  2. moshu
    Member
    Posted 7 years ago #

    Did you try removing the adsense code?

  3. mstess
    Member
    Posted 7 years ago #

    Thanks, Moshu.
    I removed the Adsense Search code and that didn't seem to help. Just went through and tried to replace stylesheet, index and others, but that didn't do anything either. I will now try to remove the other Adsense stuff, although that didn't cause a problem before.
    I am a real noob and can't think of what else to do or where else to look. I know that isn't saying much.

  4. Kafkaesqui

    Posted 7 years ago #

    At this point a link to the offending colors (i.e. your site) would help us track down the issue.

  5. mstess
    Member
    Posted 7 years ago #

    Here is the link:
    http://www.portlandtoportland.com
    Just noticed that a comment showed up in white.
    I am obviously missing something really obvious somewhere.

    Thanks for your help. I really appreciate it.

  6. Kafkaesqui

    Posted 7 years ago #

    Take a look at the following:

    http://validator.w3.org/check?uri=http%3A%2F%2Fwww.portlandtoportland.com

    All sorts of errors, not the least of which is your document actually starts with a </ul> tag! I could provide a quick CSS fix to the white text issue, but that's not going to solve the real problems here (and it'll probably resolve itself once the validation stuff is cleared up).

  7. mstess
    Member
    Posted 7 years ago #

    Be kind because I am a newbie. So, does this validator refer to a certain file? Is there some way or a program that will make the line numbers? Or do I need to count down each line?
    In the meantime, I will go search for some validation tips to see if I can figure this out.
    Thanks for your help. From my slight knowledge of html, I do know that at the start of anything isn't good.

  8. Kafkaesqui

    Posted 7 years ago #

    Return to the link I provide above and at the top you'll see a Revalidate With Options section. Check 'Show Source' and click Revalidate. Right after the error list you'll see the source of the page as the validator sees it. Also, the error #'s will link to the lines it references.

  9. mstess
    Member
    Posted 7 years ago #

    checking on that now. THanks.

  10. mstess
    Member
    Posted 7 years ago #

    OK. I have spent hours lowering the number of invalids down to 21, but I am really stuck. When is it easier to just start over from scratch? Will I lose my archives if I do this?
    I am thinking that part of my problem is because I was spellchecking outside of the page writer. Cut and paste from Word. Seems it doesn't like Times New Roman. I have no clue how to fix that or whatever else is there.
    I still have white font.

    Thanks for your help and recommendations. I am not really tech savvy and this is a very high learning curve for me.

  11. moshu
    Member
    Posted 7 years ago #

    Cut and paste from Word.

    Never do that! Especially not if you have that ugly wysiwyg thing enabled...

  12. mstess
    Member
    Posted 7 years ago #

    Thanks
    I bet that is my problem. - or one of them.
    So, what is the best way to post if not through that SYSISYG thing, which I assume is what shows up when I click on Write Post?
    And where do I even go to edit those posts. I don't see that file anywhere. I couldn't find where line 440 is after doing that validation thing.

  13. moshu
    Member
    Posted 7 years ago #

    Wysiwyg (=what you see is what you get) editor, also known as RTE (rich text editor), a.k.a TinyMCE... is the public enemy #1 :)

    To disable it:
    admin > Options > Writing: Formattin - Users should use the visual rich editor by default - UNCHECK
    admin > Users > Your profile: bottom left corner > UNCHECK

    then you'll see the code in your posts.

Topic Closed

This topic has been closed to new replies.

About this Topic