WordPress.org

Ready to get started?Download WordPress

Forums

Followed Multisite instructions... Now what? (20 posts)

  1. jheinrichs79
    Member
    Posted 2 years ago #

    Background - I am using XAMPP on a local Windows 7

    I followed the instructions here: http://codex.wordpress.org/Create_A_Network

    After completing the steps WordPress logs me out and I have to log back in. When I log back in it doesn't mention anything to do with Multisites/Super User. If you go to tools there is no network setup link anymore.

    Any Ideas?

  2. The Network Admin Link has moved with each major release of WordPress, as this is still a work in progress. Depending on which version of WordPress you are using, the link can be found in the following locations:

    * 3.0 - A menu called Super Admin
    * 3.1 - On the admin header by "Howdy, YOURNAME."
    * 3.2 - On the admin header, as a drop-down under "Howdy, YOURNAME."
    * 3.3 - A link for 'Network Admin' on the WP Admin toolbar.

  3. jheinrichs79
    Member
    Posted 2 years ago #

    Thanks Ipstenu,

    I had already found a post about the different places it has moved but there is nothing under "Howdy, YOURNAME".
    All I have showing is:
    Your profle and Log out.

    More background info:
    I'm running version 3.2.1
    I'm wanting the Networks to use subfolders rather then DNS entries so I am thinking this should make it easier to setup.

    I went back and made sure that mod_rewrite was enabled via "http://rudyegenias.wordpress.com/2006/08/21/enabling-mod-rewrite-in-xampp/"

    Under Settings Permilinks are setup like such - /blog/%year%/%monthnum%/%day%/%postname%/ <-- this means Mod_rewrite is working right?

    One thing that I found kind weird when setting up the network it say this at the top of the screen - "Warning: An existing WordPress network was detected."

  4. Go to domain.com/wp-admin/network

    What've you got?

  5. One thing that I found kind weird when setting up the network it say this at the top of the screen - "Warning: An existing WordPress network was detected."

    If you already set up the network - or JUST set it up, then yes that message is displayed under Tools -Network. to let you know you do not need to set up the network again.

    If that message was there *before* you did any setup, then we have a problem.

    But follow the link Ipstenu suggested. What happens?

  6. jheinrichs79
    Member
    Posted 2 years ago #

    It was there on the first time I tried setting things up.

    /wp-admin/network
    ======================

    [548 lines of code moderated as per the Forum Rules. Please use the pastebin]

  7. It was there on the first time I tried setting things up.

    So ... you set up multisite and it was there and then it vanished?

  8. jheinrichs79
    Member
    Posted 2 years ago #

    sorry if I wasn't clear. I just started working on a project. I have never setup a network for this installation of WordPress.

    Typically I have the Webserver and then I create seperate Full Instances of WordPress in subfolder:

    http://localhost/->Nothing here
    http://localhost/project1/ <-install WordPress here with a DB and User
    http://localhost/project2/ <- install with both different DB and User
    etc.. etc..

    I just started setting up say project5 and I figured I try Networks.
    As stated before, I followed the instructions. When it got to the part where it says copy this info and paste it into .htaccess and .wp-config.php... The Very FIRST time I saw this screen it said "Warning: An existing WordPress network was detected" at the top of the screen.

    does that explain it a bit better?

  9. So we have this:

    If that message was there *before* you did any setup, then we have a problem.

    If Project5 is brand new, wipe the DB and start over. Make 100% sure you're using a separate DB, and DO NOT use a number in the prefix (i.e. wp_ is fine, but wp4_ is not ;) )

  10. jheinrichs79
    Member
    Posted 2 years ago #

    It's not brand new :(

    Thanks for letting me know about the number in the prefix. Is there anything else you can't do? ie. like a 4 char prefix etc???

    I typically use the first few initials of the projects for the prefix. I've never used numbers. Like Hair Cutz Extreme I would use "hce_"

    Any other suggestions?

    PS - Thanks for all this help. Much appreciated.

  11. hce_ would be fine.

    Hmm. Okay, we could do this: http://wpmututorials.com/how-to/how-to-disable-multisite/

  12. jheinrichs79
    Member
    Posted 2 years ago #

    I think we're so close! I followed the instructions and tried to re-setup networks. This time it never complained that it was "Setup before".Logged out and logged back in but alas... Nothing new is under your profile except log out.

    At the time I did this I disabled ALL plugins even the first time.

  13. visit the admin url directly

    /wp-admin/network/
    What happens? There's not a network setup screen there, it;s an entire management panel.

  14. jheinrichs79
    Member
    Posted 2 years ago #

    It says that "You do not have sufficient permissions to access this page."

  15. now we're getting somewhere...

    Are you the only admin on this install?

  16. jheinrichs79
    Member
    Posted 2 years ago #

    Yup. I'm the only admin

  17. Go look at the database - did it make the extra tables?

    http://codex.wordpress.org/Database_Description#Multisite_Table_Overview

  18. jheinrichs79
    Member
    Posted 2 years ago #

    All DB items seem to have been made correctly.

  19. jheinrichs79
    Member
    Posted 2 years ago #

    The install of WordPress started out from 3.2.1
    There was no upgrades etc.

  20. I'm thinking your user did not get bumped up to super admin.

    Look in the sitemeta table.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.