WordPress.org

Ready to get started?Download WordPress

Forums

Flood Control Out of Control (14 posts)

  1. abrazell
    Member
    Posted 9 years ago #

    I upgraded to a CVS version of WP 1.5b1 last night and although I know it's not supported, I don't know if this is a dumbass user error or a problem with the code itself.

    I have had no problems with commenters or commenting at http://www.technosailor.com. However it was a quiet day which is somewhat unusual. Then, it was brought to my attention that my commenting doesn't work. When comments are submitted to ./wordpress/wp-comments-post.php, commenters are greeted with the flood control message "You can only post every 15 seconds. Slow down, cowboy". I found this thread (Slow Down, Cowboy) but unfortunately this doesn't solve my problem. The last comment in the database is from yesterday.

    Is there something up with the code or is it me and if it's me, what should I do?

  2. charle97
    Member
    Posted 9 years ago #

    make sure you overwrited all the old files with the new ones.

  3. abrazell
    Member
    Posted 9 years ago #

    That could be the issue, but I don't know. I downloaded all my old files, nuked the wordpress directory, did a CVS download which recreated the wordpress directory, then uploaded my old index.php into a new theme directory etc. The reason is is that I have a pretty hacked up wordpress so I'm trying to not have to retrace my steps. Is there one file in particular that should be overwritten? Everything else seems to work. Just this one thing.

  4. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Got any draft posts ?
    Got any altered timestamps on recent posts ?
    Tried clearing cookies ?

  5. abrazell
    Member
    Posted 9 years ago #

    No, Yes but accurately altered, Yes and this is happening on PCs I've never viewed the blog on too...

  6. RustIndy
    Member
    Posted 9 years ago #

    Yup, there's a comment bug in the Jan11 nightly for sure, I'm getting the same error.

    Gonna try to slap it around a little...

  7. charle97
    Member
    Posted 9 years ago #

    the old flood protection depended upon the $now variable, which doesn't exist in 1.5. flood protection was moved from the wp-comments-post.php file to some other file.

    are you using any flood protection plugins? if so, disable them.

  8. abrazell
    Member
    Posted 9 years ago #

    no I am not.

  9. RustIndy
    Member
    Posted 9 years ago #

    The Jan11 nightly has flood-protection built-in, but it's calculating time funny.

    In /wp-admin/functions-post.php, comment out the flood-control section from lines 447 to 454. Just stick a /* at the beginning of line 447 and a */ by itself on line 454. That'll fix it for now.

    Well, not fix, but bypass so people can post comments at least :)

  10. Kitten
    Member
    Posted 9 years ago #

  11. abrazell
    Member
    Posted 9 years ago #

    So a CVS update right now would fix that? Question about CVS. Will it overwrite files so I have to go back and do what I did last night to get set back up or can I select the files that I want to be overwritten on a selective basis?

  12. Kitten
    Member
    Posted 9 years ago #

    from your wordpress root directory, do:

    cvs up wp-includes/functions-post.php

    That will only update the one file.

  13. abrazell
    Member
    Posted 9 years ago #

    alright that did it. Thanks

  14. iJames
    Member
    Posted 9 years ago #

    Glad the problem was fixed, but in case anyone else encounters this, I'd like to offer a tip to check the timestamps on any other comments posted by that IP address. I inserted a bunch of comments manually after moving my site from Blogspot (importing turned out to be too much of a pain), and I altered the timestamps on all of them. I messed one up and set the date to December 2005 instead of 2004, and then I got that "Slow down, cowboy" error. Took me twenty minutes to figure out what was up.

    - iJames
    http://www.invisiblejames.com

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.