WordPress.org

Ready to get started?Download WordPress

Forums

Floating Social Media Links
[resolved] Floating frame displays incorrectly (4 posts)

  1. rossiback
    Member
    Posted 1 year ago #

    Hi, I have Floating Social Media Links on my site http://panpost.com and the Floating frame displays incorrectly, i have both <?php wp_head(); ?> and <?php wp_footer(); ?> in place also, I tried the templates code : <?php floating_social_media_links() ?> but non work, it displays button left with css error instead of top left or right. Any idea what i should do?

    http://wordpress.org/extend/plugins/floating-social-media-links/

  2. Nick Halsey
    Member
    Plugin Author

    Posted 1 year ago #

    For some reason, the frame lost #fsml_ff { position: fixed } from its css, which is causing the crazy x and the frame at the bottom of the page. If you add that to your theme's style.css it should fix the display for now.

    I think your caching plugin (W3 Total Cache) did this when it merged all of the stylesheets into one. Possibly because there is a comment on the same line as the position fixed. There's nothing I could do to avoid that from happening, although they could maybe improve their handling of the css.

    I noticed there is also an error with loading the hide/show script. This needs the location of wp-load.php to be able to access plugin settings, and it looks like wp-load isn't where it should be (probably something the caching plugin does). To fix this, replace
    REQUIRE $_GET['wpp'] . '/wp-load.php';
    with
    REQUIRE '[full absolute path to wp-load.php]';
    In fsml-hideshow.js.php near the top, through the plugin editor.

    If you don't know where wp-load.php is you may need to just disable hiding/showing or make more significant plugin modifications. Be aware that a plugin update is going out tomorrow and you will need to re-implement all of your changes when that happens.

  3. rossiback
    Member
    Posted 1 year ago #

    Hi celloexpressions, thanks a lot. after the above update the plugin works fine! however I was able to hide or show the frame but after adding REQUIRE '[full absolute path to wp-load.php]'; i couldn't hide it again then i undo it still I can't hide it anymore? anyway, i have decided to leave it so since update is coming soon. again thank you i really appreciate.

  4. Nick Halsey
    Member
    Plugin Author

    Posted 1 year ago #

    Update is out, which should revert and fix that change. The path probably did start working or may have for a while depending on what the caching plugin is doing.

    You would need to actually replace the absolute path to that file. I can see now from the php error (in the javascript file) that your path should be /home/u406539775/public_html/wp-load.php; either the caching plugin or your server configuration (or an incorrect entry in the absolute path to files setting in wordpress settings) is causing wordpress to report something else. The full code would be REQUIRE '/home/u406539775/public_html/wp-load.php';, and needs to replace the previous require statement to work.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic