WordPress.org

Ready to get started?Download WordPress

Forums

Flickr wont recognise xmlrpc file (34 posts)

  1. urbanmac
    Member
    Posted 9 years ago #

    I've tried to add my WP blog on flickr, on their site it says to add your url with xmlrpc.php at the end and your blog admin and password. When I do this and click submit flickr just comes back saying my endpoint is wrong?

    Any ideas?

  2. Kafkaesqui

    Posted 9 years ago #

    Does xmlrpc.php reside at this "endpoint"? In other words, is the file xmlrpc.php found in your blog directory.

  3. urbanmac
    Member
    Posted 9 years ago #

    the xmlrpc file is at:

    http://www.matandkerry.com/xmlrpc.php

    which is the url I entered into Flickr and go the error message.

  4. NuclearMoose
    Member
    Posted 9 years ago #

    I get this message when trying to view your above-posted URL:
    Fatal error: Cannot redeclare wp_insert_post()...

  5. urbanmac
    Member
    Posted 9 years ago #

    I've fixed that error by downloading and replacing the file with the one in the CVS, had to do a slight edit as its in the same directory as the wp-config file.

    I now get 'XML-RPC server accepts POST requests only.' and Flickr stills says 'not a valid endpoint'

    http://www.matandkerry.com/xmlrpc.php

  6. cutoutwitch
    Member
    Posted 9 years ago #

    I am also having this problem and I've also tried installing older versions of xmlrpc to no avail. The "BlogThis" feature worked for me until I installed the latest version of WP.

    Anyone? Help!

  7. benrad
    Member
    Posted 9 years ago #

    I'm having the same problem here, using 1.5.

  8. brightblack
    Member
    Posted 9 years ago #

    Hate to do a 'me too', but yes, my Flickr used to be fine, but after 1.5 I get nothing.

  9. tomhanna
    Member
    Posted 9 years ago #

    Solution: I was having this problem (endpoint is wrong and 'XML-RPC server accepts POST requests only) with WP1.5 Strayhorn. The solution was one of those "forest for the trees kind of things". I had the file permissions set to "644" on the xmlrpc.php file; when I reset them to 755 it worked.

    Everything worked fine although the Flickr template that was supposed to put a thumbnail and the text on one line ended up not doing that. ( http://www.tom-hanna.org/?p=629 ) That's probably CSS related and not that big a deal since it still looks ok.

    I feel like celebrating - I solved a problem instead of asking a question for once!

  10. tomhanna
    Member
    Posted 9 years ago #

    Update: Flickr told me that the blog posting had failed, but the post is on my blog. Apparently there may be something buggy, but the post actually got posted. If Flickr tells you the post failed, check your blog.

  11. brightblack
    Member
    Posted 9 years ago #

    I tried the permission change, but unfortunately no luck, so since my 1.5 update, I'm still minus Flickr! posts. Ah well.

  12. tomhanna
    Member
    Posted 9 years ago #

    You might try setting the permission to 777; the way I understand it (and that is pretty limited) the permissions are affected by who your server defines as "user", "group" and "other". At least worth a shot.

  13. dylan
    Member
    Posted 8 years ago #

    I can't get it to work with permissions set to 777 either.

  14. brainwidth
    Member
    Posted 8 years ago #

    Works fine for me. I'm using 1.5.1, with xmlrpc.php revision 2606. Permissions on the file are set to 644.

  15. freeoutdoors
    Member
    Posted 8 years ago #

    I am seeing the same error on flickr. I downloaded rev 2606 and there has been no change. I also went and tried to install Zempt to see if it would provide a bit more detail. Zempt throws an error:

    "Error! Invalid XML (<methodResponse> not found)"

  16. James
    Happiness Engineer
    Posted 8 years ago #

    WordPress v1.5.1.1 has just been released today. Make sure that you are using that version.

  17. freeoutdoors
    Member
    Posted 8 years ago #

    Done. No change.

    I turned on the xmlrpc logging, but it's not all that detailed. When I submit either with Zempt or Flickr, it logs the following. With Zempt, s/NO-APP-KEY/appKey/.

    2005-05-20 09:33:32 Input: <?xml version="1.0" encoding="utf-8"?>
    <methodCall>
    <methodName>metaWeblog.getUsersBlogs</methodName>
    <params>
    <param><value><string>NO-APP-KEY</string></value></param>
    <param><value><string>user</string></value></param>
    <param><value><string>pass</string></value></param>
    </params>
    </methodCall>

  18. freeoutdoors
    Member
    Posted 8 years ago #

    I finally took a few minutes to look closer and solved the problem. While rss-functions.php checks to see if xml_parser_create() exists, class-IXR.php does not. I didn't pay attention at the time, but the system I installed WP on happened to have an older php install that also didn't have the xml libs compiled in. What was occuring was that class-IXR.php was simply quietly dying without handling the error. Since xmlrpc.php already has flags to turn on debug logging, perhaps these should be used throughout.

    After an upgrade, xmlrpc.php functionality works great.

  19. galfn
    Member
    Posted 8 years ago #

    I have upgraded to 1.5.1.2
    but it still not work, anyone knows how to configure it?
    Thanks in advance

  20. pieceoplastic
    Member
    Posted 8 years ago #

    @ freeoutdoors: if i understand you correctly in order for xmlrpc to work there should be certain xml libs compiled server side? is that correct? because i can't seem this to work with any of the dashboard widgets and i have played around with switiching poermissions and upgrading to the latest latest version. with no luck. my hosts are running php5.

    edit: i receive the following error:

    Notice: Undefined variable: HTTP_RAW_POST_DATA in /path/to/my/blog/xmlrpc.php on line 4

  21. Berko
    Member
    Posted 8 years ago #

    I had a similar problem as well. It worked fine on a fresh install but not on my veteran blog. Anyway, in the end, running upgrade.php solved it for me. I stumbled upon this inadvertently when I was trying to figure out why my site was causing a file download instead of displaying my content. upgrade.php was the answer.

  22. warquel
    Member
    Posted 8 years ago #

    Make sure that the user account that you are using to post pictures from flickr has a level greater than 1. If the user is at level 1 it will not work.

  23. Pentadact
    Member
    Posted 8 years ago #

    Upgrade.php fixed it for me too! Awesome. I was so happy I blogged a photo of it:

    http://www.kfj.f2s.com/index.php/2005-08-15-wordpresss-wizard-3

  24. cczona
    Member
    Posted 8 years ago #

    None of this is working for me. A fresh install of WP 1.5.2 returns the same "endpoint" error via Flickr, and "POST" error via direct URL. Changing permissions to 777 hasn't helped, neither has running upgrade.php. The user account is level 10.

    Any other ideas out there? Others are still reporting this error in 1.5.2

  25. KiwiNessie
    Member
    Posted 8 years ago #

    Has this problem now gone away for everyone or have you all given up? I still can't post photos from Flickr to my blog and I have upgraded to WP 1.5.2.

  26. dhkeller
    Member
    Posted 8 years ago #

    check your caps/CAPS in the names of the files called by the xmlrpc file. "class-IXR.php" in your wp-includes folder needs to match case with the call inside xmlrpc. I fixed that, and it finally worked for me.

  27. spoofhound89
    Member
    Posted 8 years ago #

    Problem hasn't gone away. I've given up trying. I've done everything listed here and everything I can find at Flickr's support forums and I have nothing to show for it.

  28. chimommy
    Member
    Posted 8 years ago #

    I had this problem too and all it took was re-uploading the xmlrpc file and it worked. I have no idea what was causing it not to work though. Would uploading a fresh copy of the file help?

  29. spoofhound89
    Member
    Posted 8 years ago #

    Did it.

    I'm using version 1.5.2 just in case anyone wonders.

  30. iceman42
    Member
    Posted 8 years ago #

    class-IXR.php will cause issues as well in the 1.5.2 version of WP, go grab the svn release of class-IXR.php and replace the class-IXR.php in you wp-includes directory.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags