WordPress.org

Ready to get started?Download WordPress

Forums

Flickr Blog This to WordPress 2.0 - CSS Removed? (14 posts)

  1. edgillett
    Member
    Posted 8 years ago #

    I'm encountering an issue attempting to post my flickr images to my blog.

    Problem is, when it arrives in WordPress, it's lost most of the style information. It removed the class attribute on a DIV, and removed a SPAN tag in its entirety. I've also tried inline styles and it's stripped this too! Is this Flickr or WordPress?

    Have searched around both Flickr and WordPress forums, but can't find anything similar.

    Anyone run into this one? Not sure if it's Flickr's end or some weirdness when it gets to my WordPress install?

    I'm using WordPress 2.0 on my own server.

  2. edgillett
    Member
    Posted 8 years ago #

    http://www.flickr.com/forums/bugs/17025/

    Looks like I'm not alone and this is a break in functionality since version 1.5 to WordPress 2.0.

    Any comment from Devs? Further info required?

  3. ccf
    Member
    Posted 8 years ago #

    No, you are not alone, I am experiencing the same issue. It didn't happen in 1.5

  4. Annelogue
    Member
    Posted 8 years ago #

    I have the same problem after I upgraded from WP 1.5 to 2.0. It does not seem to accept css code in post....

    <style type="text/css">
    .flickr-photo { border: solid 2px #000000; }
    .flickr-yourcomment { }
    .flickr-frame { text-align: left; padding: 3px; margin-top: 0 0 5px 15px; }
    .flickr-caption { font-size: 0.8em; margin-top: 0px; }
    </style>

    <div class="flickr-frame">
    <img src="{photo_src}" class="flickr-photo" width="390" height="292,5" alt="" />

    <span class="flickr-caption">{photo_title}, originally uploaded by {uploader_name}.</span>
    </div>

    <p class="flickr-yourcomment">
    {description}

    What can you do about this problem? Thanks for any hints.

  5. ccf
    Member
    Posted 8 years ago #

    Not only are posts from BlogThis stripped from their CSS, but some tags remain, like an isolated <div> which screws the appearance of the blog.
    Hope someone has realised what is going on and will fix it soon, as in every other way, WordPress 2.0 is just so great.

  6. Polyakov
    Member
    Posted 8 years ago #

    Please... help us, We urgently need it, it's a grave to manually reformating posts... I hate it.

  7. technoag
    Member
    Posted 8 years ago #

    I think this may have been fixed in the 2.1

    http://trac.wordpress.org/ticket/2241
    http://trac.wordpress.org/ticket/2287

    But I haven't had a chance to install it and see.

  8. tanster
    Member
    Posted 8 years ago #

    Just tried this with WordPress 2.0.1, and yes, it seems to work now! :)

    Update: Sorry, I thought it worked, but it didn't. Tried copying Annelogue's CSS into my Flickr layout, but the CSS didn't come through correctly. :(

  9. virtuallynicky
    Member
    Posted 8 years ago #

    Hi, mine is working now, after upgrading to 2.0.1, although I use different css to Annelogue.

  10. ccf
    Member
    Posted 8 years ago #

    It's working for me too! :) Thanks to everyone in the WordPress team!

  11. toopicky
    Member
    Posted 8 years ago #

    Still doesnt work for me... do I need to change permissions on on the file itself? xmlrpc.php ?

    And when I try to re setup a my blog via flickr it keeps telling me that "The endpoint you entered was not correct."

    Used to work fine in 1.5x 2.0 broke it upgraded to the latest 2.0.1.

    It does not even send the post for me.
    my endpoint would be http://toopicky.com/wp/xmlrpc.php

  12. rbieber
    Member
    Posted 8 years ago #

    I've upgraded to version 2.0.1 and am still having the problem. All style and class attributes are stripped, and in one sample post even the src attribute from the image tag was removed.

  13. ccf
    Member
    Posted 8 years ago #

    For some reason, it worked for a week or so with the worpress 2.0.1 update and has returned to NOT working :(
    No one seems to care...

  14. toopicky
    Member
    Posted 8 years ago #

    ccf:

    I agree.. But hey the product was free and all other functions work like i would have have to pay $1000 bucks for it.

    I'd love to get the flickr postings to work.

Topic Closed

This topic has been closed to new replies.

About this Topic