WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Flickr auto embed sizing problem in 3.4 (13 posts)

  1. Truth
    Member
    Posted 2 years ago #

    After updating to 3.4, even when my settings have embed width at 500px, my flickr photos still ended up in 320px. This issue only occurs after the update for new post.

    Have tried re-saving the options but it's not working. Any suggestions please?

    Thanks!

  2. Truth
    Member
    Posted 2 years ago #

    I'm still having this problem. Tried on an older version and WordPress and have no issue so I'm very sure this only happens in 3.4. Any help would be appreciated. Thanks!

  3. gelle
    Member
    Posted 2 years ago #

    I'm having this problem as well. Have you found any solution?

  4. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    Try reverting to the default theme Twenty Eleven and see if the problem persists.

  5. gelle
    Member
    Posted 2 years ago #

    Thanks Krishna, but that did not help me.

  6. Truth
    Member
    Posted 2 years ago #

    No solutions yet! I have tested it on older version of WordPress and it doesn't have this issue so I'm pretty sure it's not on Flickr side. Any ideas anyone?

  7. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    Either your theme may have set sizes for images/thumbnails, or some plugins may be resizing images. If these two are not set, the image size that you set in Flickr.com can be posted directly to your blog. I think the maximum width available in Flickr.com for direct posting is 500px. You can also set width in html options in Flickr.com and post. These are the things I have noted and they work fine for me.

    Edit: It worked for older versions of WP, and even the latest version for me.

  8. gelle
    Member
    Posted 2 years ago #

    I think this is a peculiar problem and my solution is equally hacky.

    In Settings > Media > Embeds, I tried changing the size back and forth between 320 and 500 and nothing happened. But if I went above 640 I would get images that were 640px wide. Too big for my theme but my solution so far has been to scale them down using CSS so I have added this to my custom CSS file:

    .entry-content img {
    max-width : 500px;
    height :auto;
    }

    Not sure why I can get 320px and 640px but not 500px. Could it be a Flickr setting? I had a look and didnt find anything interesting.

    Do post if you find other solutions were it works with the proper size of 500px.

  9. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    @gelle,
    Do you post directly from Flickr using the blogging options of Flickr? I do that way.

  10. gelle
    Member
    Posted 2 years ago #

    No, I use the newish "auto embed" function to include my pictures from flickr in my posts.

    That way I can just post the link in the editor and WordPress (used to) just fetch the 500px version of that url and insert it in the post.

    The blog is here: http://hejsonderborg.dk

  11. theonetruebix
    Member
    Posted 1 year ago #

    Has this been acknowledged at all? I've gotten gelle's kludge working, but it does seem peculiar that the auto-embed for Flickr URLs is not grabbing a size suitable for standard theme widths.

  12. theonetruebix
    Member
    Posted 1 year ago #

    And now it's broken in WordPress 3.5, which isn't even presenting me with a Settings > Media> Embed option anywhere. What am I missing?

  13. esmi
    Forum Moderator
    Posted 1 year ago #

    As per the Forum Welcome, please post your own topic. Your problem - despite any similarity in symptoms - is likely to be completely different.

Topic Closed

This topic has been closed to new replies.

About this Topic