WordPress.org

Ready to get started?Download WordPress

Forums

Autoptimize
[resolved] flickering/spining advice-fix (3 posts)

  1. omduk
    Member
    Posted 4 months ago #

    First of all thanks for great plugin.

    Question:
    What is the best way to fix flickering/spining of pages that contain video material (embeded players, ustream and youtube) ?
    That pages spin without stop and dont load.
    Some exclude example or word of advice would be good.

    My Autoptimize configuration is:
    Optimize HTML Code: checked
    Optimize JavaScript Code: checked
    Optimize CSS Code: checked
    Save aggregated script/css as static files: uncheked.

    Related plugins:
    Advanced Responsive Video Embedder

    WordPress theme:
    Hueman

    https://wordpress.org/plugins/autoptimize/

  2. futtta
    Member
    Plugin Author

    Posted 4 months ago #

    guess first thing to do is disable js optimization and see if that fixes things (it probably will).

    after that, re-enable but with "force js in head" which might fix this.

    if not (or if you don't want all in head), look for javascript used by "Advanced Responsive Video Embedder" and exclude that. based on a quick look at the plugin i think you'd have to exlude "public.js, jquery.js", but jquery could also be "jquery.min.js" or "jquery-min.js" (depends on your theme). lastly "colorbox" (a jquery plugin) might have to be excluded as well.

    hope this helps,
    frank

  3. omduk
    Member
    Posted 4 months ago #

    Tryed all
    and fixed it with enabling this:
    Force JavaScript in <head>
    Add try-catch wrapping

    Thanks

Reply

You must log in to post.

About this Plugin

About this Topic