WordPress.org

Ready to get started?Download WordPress

Forums

Flexslider issue, Image keeps jumping down! (2 posts)

  1. Itechmatrix
    Member
    Posted 1 year ago #

    Hello,
    I have a wordpress site running on the theme valor which comes with a flexslider pre installed. As you can see:
    http://www.itechmatrix.com/
    the slider keeps shifting down inbetween transitions. How do i fix this?
    P.S here is all the CSS for the flexslider:

    /*
    * jQuery FlexSlider v1.8
    * http://www.woothemes.com/flexslider/
    *
    * Copyright 2012 WooThemes
    * Free to use under the MIT license.
    * http://www.opensource.org/licenses/mit-license.php
    */

    /* Browser Resets */
    .flex-container a:active,
    .flexslider a:active,
    .flex-container a:focus,
    .flexslider a:focus {outline: none;}
    .slides,
    .flex-control-nav,
    .flex-direction-nav {margin: 0; padding: 0; list-style: none;}

    /* FlexSlider Necessary Styles
    *********************************/
    .flexslider {margin: 0; padding: 0;}
    .flexslider .slides > li {display: none; -webkit-backface-visibility: hidden;} /* Hide the slides before the JS is loaded. Avoids image jumping */
    .flexslider .slides img {max-width: 100%; display: block;}
    .flex-pauseplay span {text-transform: capitalize;}

    /* Clearfix for the .slides element */
    .slides:after {content: "."; display: block; clear: both; visibility: hidden; line-height: 0; height: 0;}
    html[xmlns] .slides {display: block;}
    * html .slides {height: 1%;}

    /* No JavaScript Fallback */
    /* If you are not using another script, such as Modernizr, make sure you
    * include js that eliminates this class on page load */
    .no-js .slides > li:first-child {display: block;}

    /* FlexSlider Default Theme
    *********************************/
    .flexslider {background: #fff; position: relative; -webkit-border-radius: 5px; -moz-border-radius: 5px; -o-border-radius: 5px; border-radius: 5px; zoom: 1;}
    /* .flexslider .slides {zoom: 1;} */
    .flexslider .slides > li {position: left;}
    /* Suggested container for "Slide" animation setups. Can replace this with your own, if you wish */
    .flex-container {position: top;}

    /* Caption style */
    /* IE rgba() hack */
    .flex-caption {background:url(images/trans.png);}
    .flex-caption {width: 950px; padding: 2% 25px; margin: 0; position: absolute; left: 0; bottom: 0; background: rgba(f,f,f,.3); color: #000; font-size: 14px; line-height: 22px;}
    .flex-caption h3{ text-transform:uppercase; font-weight:700; color:#000; margin-bottom:5px;}
    /* Direction Nav */
    .flex-direction-nav { height: 0; }
    .flex-direction-nav li a {width: 32px; height: 32px; margin: -16px 0 0; display: block; background: url(images/bg_direction_nav.png) no-repeat; position: absolute; top: 50%; cursor: pointer; text-indent: -999em;}
    .flex-direction-nav li .next {background-position: -32px 0; right: 20px;}
    .flex-direction-nav li .prev {left: 20px;}
    .flex-direction-nav li .disabled {opacity: .3; filter:alpha(opacity=30); cursor: default;}

    /* Control Nav */
    .flex-control-nav {width: 100%; position: absolute; bottom: -30px; text-align: center;}
    .flex-control-nav li {margin: 0 0 0 5px; display: inline-block; zoom: 1; *display: inline;}
    .flex-control-nav li:first-child {margin: 0;}
    .flex-control-nav li a {width: 13px; height: 13px; display: block; background: url(theme/bg_control_nav.png) no-repeat; cursor: pointer; text-indent: -999em;}
    .flex-control-nav li a:hover {background-position: 0 -13px;}
    .flex-control-nav li a.active {background-position: 0 -26px; cursor: default;}

  2. ouija
    Member
    Posted 1 year ago #

    Try using useCSS : false in your javascript initialization for flexslider and see if that helps? A long shot but might be worth a try.

    Looking quickly at your css, I would try changing .flexslider .slides img {max-width: 100%; display: block;} to .flexslider .slides img {max-width: 99%; display: block;} or maybe '.flexslider .slides img {max-width: 100%; display: inline-block;}` or a variation of the two and see if maybe that helps.

Topic Closed

This topic has been closed to new replies.

About this Topic