WordPress.org

Ready to get started?Download WordPress

Forums

flash uploader security error problem (11 posts)

  1. dovydas
    Member
    Posted 3 years ago #

    When I try uploading a file using Flash Uploader I get security error. Browser Uploader works fine. I was using wordpress 3.0, then upgraded to 3.0.1 but it didn't help.

    I have another wordpress installation in another directory in the same server. Flash Uploader works fine here. The version number of working installation is 2.8.3.

    Here is a copy of .htaccess. It is the same on both installations:
    # cat .htaccess

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    What should I do to make Flash Uploader work?

  2. Can you quote the security error?

  3. dovydas
    Member
    Posted 3 years ago #

    It is just "Security error." Written in red font. That's it.

    Upload New Media
    Security error.
    Choose files to upload [Select Files] [Cancel Upload]
    Maximum upload file size: 2MB

    You are using the Flash uploader. Problems? Try the Browser uploader instead.
    After a file has been uploaded, you can add titles and descriptions.

  4. dovydas
    Member
    Posted 3 years ago #

    I have googled out somewhere that server configuration may cause problems. To be exact: mod_security module. However I don't have this module loaded. Here is a list of my modules:

    # apache2ctl -M
    Loaded Modules:
    core_module (static)
    log_config_module (static)
    logio_module (static)
    mpm_prefork_module (static)
    http_module (static)
    so_module (static)
    alias_module (shared)
    auth_basic_module (shared)
    authn_file_module (shared)
    authz_default_module (shared)
    authz_groupfile_module (shared)
    authz_host_module (shared)
    authz_user_module (shared)
    autoindex_module (shared)
    deflate_module (shared)
    dir_module (shared)
    mime_module (shared)
    negotiation_module (shared)
    php5_module (shared)
    reqtimeout_module (shared)
    rewrite_module (shared)
    setenvif_module (shared)
    Syntax OK

    I believe that server is OK, because I have one working wordpress installation on the same server. It may be some directory permissions or some other configuration options different. I just don't know what to look for and what to compare on working and non-working instances.

    Any advices would be appreciated.

  5. dovydas
    Member
    Posted 3 years ago #

    And I have found yet another two instances of wordpress installations on the same server that has Flash Uploader working fine. The version numbers of these installations are 2.9 and 2.9.1

    I can't find any differences between all these different installations. WordPress 2.8 and 2.9 and 2.9.1 are working fine. But 3.0 and 3.0.1 have some problems. These installations have the same settings and use the same database.

    Any clues?

  6. dovydas
    Member
    Posted 3 years ago #

    I have just upgraded wordpress 2.9.1 with working Flash Uploader to 3.0.1. And Flash Uploader still works fine after upgrade! So the problem lies not with 3.0 version number but elsewhere...

  7. Try decativating all plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the Twenty Ten theme to rule-out a theme-specific issue (theme function can sometimes interfere with the admin panel).

  8. dovydas
    Member
    Posted 3 years ago #

    I was using Twenty Ten theme already.

    I deactivated all plugins but Flash Uploader still doesn't work.

    The only difference between working and non-working sites I can think of is that non-working site has IDN domain name and all working sites have ASCII domain names.

  9. dovydas
    Member
    Posted 3 years ago #

    I have made fresh wordpress 3.0.1 installation on new site with IDN domain name. Flash Uploader failed with "security error".

    I have filled bug report in trac: Ticket #14648.

  10. bearvv
    Member
    Posted 3 years ago #

    Me too, I got the same problem when I upload image.

    I am using wordpress 3.01 + multisite + domain mapping.

  11. dovydas
    Member
    Posted 3 years ago #

    In case anyone still has this problem there is a solution for flash uploader on IDN sites problem.

Topic Closed

This topic has been closed to new replies.

About this Topic