WordPress.org

Ready to get started?Download WordPress

Forums

Flash problem (3 posts)

  1. Pred88
    Member
    Posted 4 years ago #

    Hi,

    I have a problem embedding a flash movie in my sidebar. The problem is that the movie isn't showing. It is loaded but just won't show. I've tested it by putting the exact same code in a html file, that worked fine. But when I put it in sidebar.php it doesn't work anymore.

    Ive tried changing the publish settings and after changing it to AS3 (instead of AS2 which it was made in) I do get something. Of course not working as it should since the banner is in AS2, but at least it shows something.

    Does anyone have an idea how I can solve this ?

    link to website: http://ijzerhandel-amsterdam.nl/new/wordpress/
    link to working html file: http://ijzerhandel-amsterdam.nl/new/wordpress/wp-content/themes/ijzerhandel/test.html

  2. whooami
    Member
    Posted 4 years ago #

    in the html file:

    <embed wmode="transparent"
    src="http://ijzerhandel-amsterdam.nl/new/wordpress/wp-content/themes/ijzerhandel/banner.swf"
    quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash"
    width="200" height="250"></embed>

    in wordpress:

    <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="200" height="250">
            <param name="movie" value="http://ijzerhandel-amsterdam.nl/new/wordpress/wp-content/themes/ijzerhandel/banner.swf" />
            <!--[if !IE]>-->
            <object type="application/x-shockwave-flash" data="http://ijzerhandel-amsterdam.nl/new/wordpress/wp-content/themes/ijzerhandel/banner.swf" width="200" height="250">
            <!--<![endif]-->
              <p>Alternative content</p>
    
            <!--[if !IE]>-->
            </object>
            <!--<![endif]-->
          </object>

    does that look the same to you? when you have properly formatted the code necessary to display flash objects, im guessing it'll show up.

  3. Pred88
    Member
    Posted 4 years ago #

    oh right im trying diffrent ways to embed it as we speak. What I ment is that using the same method that worked in the html doesn't work for the sidebar.php

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.