WordPress.org

Ready to get started?Download WordPress

Forums

Flash links are not working in my header file (19 posts)

  1. Anonymous
    Unregistered
    Posted 5 years ago #

    Hey! I did a search on google and here for this and never came up with an adequate solution. Now, usually once I boot up my computer and check out the blog page, the flash header links are working just fine. However, after one or two times of clicking on it, it just stops working altogether. The flash file and required javascript is embedded absolutely.

    So is there some quirk with WordPress that is causing this? Does anybody have a clue how to make this work? Is it a version issue? Help!

  2. Anonymous
    Unregistered
    Posted 5 years ago #

    Ok, this site has to go live, so I need to take the header down and replace it with images for now... but the plea for help still stands.

  3. lightsail
    Member
    Posted 5 years ago #

    Mine are also not working but they where at one time what's up
    http://chicagoboxing.com/news/

  4. Anonymous
    Unregistered
    Posted 5 years ago #

    I'm having this same problem...

    I have a flash file with absolute links on the buttons. When you click the buttons nothing happens. When the flash file is in an html page, the links work fine. HTML links on the page work perfectly. I've tried rebuilding the code embedding the flash file, but no luck.

    Is there anyone out there that can help?

  5. Anonymous
    Unregistered
    Posted 5 years ago #

    Still waiting for any kind of response at all... this is a major thing if I can't use flash in my wordpress layouts.

  6. emme
    Member
    Posted 5 years ago #

    I am dealing with this same issue. If I have any luck I'll be sure to let you know!

  7. emme
    Member
    Posted 5 years ago #

    My instinct is that this is some kind of security issue within WordPress.

    I'm having limited* success doing the following:

    1. Using SWFobject to embed the Flash file
    2. Using complete paths for both the embedding of the Flash file and the URLs it links to
    3. Placing the .swf in the root directory of the selected blog theme (e.g. httpdocs/wp-content/themes/theme_name/flash_file.swf)

    *Limited success means it is working fine in:
    IE on PC and Mac
    Safari on Mac

    But bizarrely when viewing my slideshow using Firefox (on both PC and Mac) the links only work in the top third of the Flash file area! No idea why this is. Trying to figure it out now...

    Hope this helps! Let me know how you get on...

  8. mousi999
    Member
    Posted 5 years ago #

    I'm having the same problem. I've tried the typical swf object to embed and the kimili plugin for wordpress.

    The file loads, and rotates through the images, but the links don't work. Click, and nothing happens.

    The swf file works on all the other pages on the site. The links are absolute.

    Any suggestions?

  9. llamaman
    Member
    Posted 5 years ago #

    Hi!
    I was experiencing the same problem, and here's how I fixed it.

    In your template file (probably header.php), you have some Flash code like this:

    <script language="javascript">
    	if (AC_FL_RunContent == 0) {
    		alert("This page requires AC_RunActiveContent.js.");
    	} else {
    		AC_FL_RunContent(
    			'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0',
    			'width','313',
    			'height','100',
    			'id','flashFileNameHere',
    			'align','middle',
    			'src','flashFileNameHere',
    			'quality','high',
    			'wmode','transparent',
    			'bgcolor','#ffffff',
    			'name','flashFileNameHere',
    			'allowscriptaccess','always',
    			'allowfullscreen','false',
    			'pluginspage','http://www.macromedia.com/go/getflashplayer',
    			'movie','flashFileNameHere'
    		); //end AC code
    	}
    </script>

    The secret to getting the links to work for me was to make sure that "allowscriptaccess" is set to "always" and not to "sameDomain" or something else.

    I hope this helps!

  10. sloganmedia
    Member
    Posted 5 years ago #

    The solution is very simple (after a headache):

    it is only necessary to include the following path before the flash file:

    <? php bloginfo ( 'stylesheet_directory');?> / images / fileflash.swf

    Same in the Scrip:

    <? php bloginfo ( 'stylesheet_directory');?> / images / AC_RunActiveContent.js

    That's all! :)

  11. rusteberg
    Member
    Posted 5 years ago #

    sloganmedia,

    if you have successfully installed a working swf in your blog, then can you please post the code in full as it appears in your header.php? I am having a hard time following your last post.

    thanks!

  12. BionicDrew
    Member
    Posted 5 years ago #

    I was having the same problem - the links in my flash movie only worked half the time. The solution was to use a preloader as this ensures that the links load every single time. It appears that this bug only appears in Firefox.
    I would put a link up here but it is a private system unfortunately.

  13. brent3721
    Member
    Posted 5 years ago #

    if you were using a mirrored domain when you setup the site and then made the site live by changing setting the nameservers to the actual domain, your mirrored domain info is still in the database and in our case caused us to not be able to use links in flash movies for one of our clients. You can fix this pretty easily by going into phpmyadmin on your server and searching the mirrored subdomain and replacing it manually with the actual domain (that's the only way I know how to do it anyway, didn't see anything in the admin for wp)

    brent
    @
    mimoymima.com

  14. josheat
    Member
    Posted 5 years ago #

    I found a solution to the problem that should work for everyone.

    Use this plugin to embed the flash:
    http://kimili.com/plugins/kml_flashembed/wp

    And generate the code with this page:
    http://www.bobbyvandersluis.com/swfobject/generator/index.html

    Now what you got to do, is make sure allowscriptaccess and allownetworking are set as always and all. (thanks llamaman for the heads up, but this plugin needs allownetworking too)

    Where the generator says "Publishing method", make sure that is set to static. Copy the <object> code from the generator to your theme template, but not the js link in the header (I could never get the flash to show up with it in there, even with the correct url). Also make sure the object points to the right url for the flash movie. eg: <? php bloginfo ( 'stylesheet_directory');?>/movie.swf

    This is the only solution that worked for me.

  15. ckirby
    Member
    Posted 5 years ago #

    I just got a SWF ad to play in a WordPress header by doing the following:

    1. I created a new html page in Dreamweaver.
    2. I imported the SWF file to the page.
    3. I switched to Code view and copied-and-pasted the code.
    4. I pasted the code into the appropriate place in the WordPress header template.
    5. I manually added the a href link code around the entire piece of embed code.

    Worked for me. :-)

  16. glassrabbit
    Member
    Posted 5 years ago #

    not for me. I have tried each of the above and had no success.the swf file doesnt care if its in the root or not. but the links dont work. IF someone could help me step by step I would be grateful.
    blog is: http://www.firefly-glass.com/blog
    also I am not so good at the kimili flash plug in, I see the tab for general posts and use it for that. but I have no idea how to alter a header using that Kimili plug in.

    Thanks in advance for any help.

  17. glassrabbit
    Member
    Posted 5 years ago #

    I managed to get this to work and I am not sure if it will work for you I posted it here
    http://www.firefly-glass.com/headerfix.htm

  18. reelequity
    Member
    Posted 5 years ago #

    WOW -glassrabbit ! that worked for me thank you so much!
    http://www.reelequity.tv

  19. Floyd1482
    Member
    Posted 5 years ago #

    Thanks glassrabbit, that worked for me too

    Thank you so much

Topic Closed

This topic has been closed to new replies.

About this Topic