WordPress.org

Ready to get started?Download WordPress

Forums

Flash intro loading before index.php (6 posts)

  1. bambam4479
    Member
    Posted 9 years ago #

    I had a flash intro developed for our site, however the way it was implemented was into an index.html file. When I put the index.html and the .swf file into the appropriate location the index.php loads first instead of the index.html. Does anyone know of a way to get around this? I tried searching the forum but couldn't find anything.

  2. PsychoDJ
    Member
    Posted 9 years ago #

    Your webserver loads the index files in the order you type them. For instance, in IIS if index.php is above index.htm, it will load first. Same for Apache, if index.php is first in the list, it loads first. To get your index.htm to load first, you need to change the order on the web server.

  3. bambam4479
    Member
    Posted 9 years ago #

    Thanks Psycho, but where do I go to change this setting? I'm running Apache on a Fedora Core 1 server.

  4. mattmend
    Member
    Posted 9 years ago #

    In your httpd.conf file. Depending on your OS' install, possibly /etc/httpd/
    Hope it helps.
    Matt

  5. Stevarino
    Member
    Posted 9 years ago #

    Try dropping this in your .htaccess file:
    DirectoryIndex index.html index.htm index.php

  6. bambam4479
    Member
    Posted 9 years ago #

    I don't want to modify the machine's settings so I tried Stevarino's suggestion and it worked!
    Thanks Stevarino, I owe you one :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.