WordPress.org

Ready to get started?Download WordPress

Forums

Flash embedding won´t store properly. Have to re-add code over and over (7 posts)

  1. Marius-
    Member
    Posted 4 years ago #

    In WordPress, I use embedding alot in my posting. Mostly Youtube, which works fine.

    But then there are other websites you can embed from, which has a slightly different code. Like Google Maps.

    These codes often include "iframe" in their embed-code, and whenever I add this to one of my pages or posts in WordPress, switching to Visual View will delete this code for some unknown reason.

    So in order to store the code permanently, I have to add it HTML-view, and save it, without ever switching back to visual view. This is obviously a bug, and I hope someone fixes it. Has anyone of you tried embedding Google Maps?

    Is there anything I can do?

  2. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    As far as I know, the only option is to not switch to visual from html

  3. Marius-
    Member
    Posted 4 years ago #

    Yes, thats what I just said.
    So I take you´ve encountered the same problem?

    This cant possibly be only me here.

  4. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    no no, I've seen it in action, and many people have asked about it here.

    I don't believe there is any solution, other than not switching to the visual editor.

    Kind of lame.....but it is what it is I guess......

  5. Marius-
    Member
    Posted 4 years ago #

    Well iframe is surely an old way of coding. I remember using it way back in the 90´s. Has it something to do with WordPress using a different structure, and iframes obscuring the code in some way?

    Since WordPress is getting so big, and blogging consists of alot of embedding, I would think the WordPress lords would fix this problem.

  6. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    dunno if its iframe related...

    WP really just has a problem switching between the visual/html

    even with pretty standard html coding, you will lose stuff switching between the 2

  7. Mike Logan
    Member
    Posted 4 years ago #

    Yes...this IS HORRIBLE. I use iframe to insert Forms from formboss and one accidental click and POOF...it is gone so I have to keep the code handy at all times so I can re-insert it via the html side of the editor. Also when using iframe, any line break code you try to use BEFORE it will NOT work??? That means you can not custom space between the end of your content right before your iframe.

    Also I have huge beefs about that html editor anyhow. Ya try to do some coding in it and the damn thing jumps around all over the place meaning you could be working on let's say line 145 (estimate) and it will jump back to the top of the document! Very irritating. Is there a way to fix that??? I sure hope.

    Thanks folks

    peace out,
    daddylogan

Topic Closed

This topic has been closed to new replies.

About this Topic