WordPress.org

Ready to get started?Download WordPress

Forums

Flare
Flare and w3 Total Cache minify... (3 posts)

  1. bakbek
    Member
    Posted 1 year ago #

    Hi, I'm trying to get Flare working while using w3 total cache with minify on for JS and CSS - not working so far :(

    ( see here an example - http://www.ronenbekerman.com/photographic-approach-in-architectural-visualisation/ )

    Is this something on my site and loading order issue, or a w3 total cache thing, or a flare thing - or a mix of all combined? Would love to know how to make this all work.

    http://wordpress.org/extend/plugins/flare/

  2. Hans Christian
    Member
    Posted 1 year ago #

    Hi! I've the same problem here.

    I've take a look to your example site and I can see that you've resolved the problem (I can see the Flare sidebar working fine and the JS minified).

    How did you resolved this?

    Thank you so much :-)

  3. semantomics
    Member
    Posted 12 months ago #

    Apparently, there's are many JS that cannot be minified. But if you're using W3Tcache, then you could solve this by manually selecting the files to be minfied and those to do not minify.

    1) go to Performance>General settings> [tick: enable; manua] and leave deafults
    2) save all settings
    3) go to Performance>Minify>
    4) click [empty cache] ;
    5) click [help] >> here you will see a list of suggested stuff;

    Once this popover loads up you will be faced with a list of javascript files, followed by stylesheets that your site is linking to. Essentially we want to try and tick everything EXCEPT:
    -Jquery files
    -Google ads (or any ads for that matter)
    -Any stats.wordpress.js files (you will have these if you have jetpack installed
    However for CSS you can pretty safely select all of them. Now this isn’t an exact science as this is minifying your theme files (Don’t worry it’s non destructive) and there are alot of different themes all employing a wide range of different files, plugins and functions. Like my theme file cannot be minified because i'm using a child-theme (that use @import).
    So (expect from other your basical settings):
    -In the javascript list do not put http://www.yourwebsite.com/wp-content/plugins/flare/js/flare.js?ver=1.2.4the css
    And in the css list do not put http://www.yourwebsite.com/wp-content/plugins/flare/css/flare.css?ver=1.2.4

    6) Basically preview your changes before submitting them.
    Minify is one of the biggest improvements you will be integrating, once you have selected all your files (and done the same with every theme, if you are using more than one) then click “Apply & close”, directly followed by “Save all settings” (Deploy it if your site still looks/works the same).

    Hope you can solve it.. ask me if you have some issues!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.