WordPress.org

Ready to get started?Download WordPress

Forums

Fix WP runtime errors on GoDaddy (6 posts)

  1. mdolf
    Member
    Posted 4 years ago #

    I often get runtime errors (see below for the error), at least a couple times a day, which puts my blog out of commission for at least 5 minutes at a time. I am trying to figure out how to get custom errors to show so I can fix the problem. I have tried everything I could think of and just can't figure this out.

    I have installed wp on godaddy on a windows-based hosting plan. Apparently this doesn't support .htaccess (which is what most help forums refer to). Apparently I need to edit a web.config file but godaddy doesn't show the web.config file so apparently I need to create one. I created a web.config.php file on my FTP client with the following text:

    <configuration>
      <system.web>
        <customErrors mode="Off"/>
      </system.web>
    </configuration>

    Still doesn't work. Can anyone suggest a solution? Thanks very much in advance.

    Runtime Error
    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

    '<!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="Off"/>
    </system.web>
    </configuration>'

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    '<!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
    </configuration>'

  2. MichaelH
    Member
    Posted 4 years ago #

    Last time I looked, WordPress didn't work with Godaddy's Windows hosting. Change to a Linux hosting plan.

  3. mdolf
    Member
    Posted 4 years ago #

    It may not do a good job hosting WordPress but it certainly should work. Plus the not too helpful GoDaddy reply I got said it would work but that I should go find the answer for how to do it on other forums. WP has been working fine for the past few weeks on this hosting system (except for this issue).

  4. Samuel B
    moderator
    Posted 4 years ago #

    as MichaelH stated...you will continue to have problems despite what godaddy says
    switch to linux for free

  5. mdolf
    Member
    Posted 4 years ago #

    OK, will try that. Thanks.

  6. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    I started on Godaddy windows and had problems with everything. Switched over to Godaddy linux, and have never had a problem

Topic Closed

This topic has been closed to new replies.

About this Topic