WordPress.org

Ready to get started?Download WordPress

Forums

Fix WordPress RSS feeds (10 posts)

  1. Anonymous
    Unregistered
    Posted 9 years ago #

    By default wordpress shows these RSS feed links:
    http://www.bhatt.id.au/blog/feed/rss2/
    http://www.bhatt.id.au/blog/feed/rss/
    http://www.bhatt.id.au/blog/feed/atom/
    etc
    However, Google looks for RSS feeds named:

    • rss.xml - for an RSS 0.92 or 2.0 feed
    • index.rdf - for an RSS 1.0 feed
    • atom.xml - for an Atom RSS news feed

    This means that each day when the GoogleBot visits my Blog, it generates many 404 file not found errors in my website logs by asking over and over again for :

    After 15 such errors in the last hour I decided to see what I could do to fix this so that WordPress would display links to my RSS feeds which would stop GoogleBot hassling me with errors....
    How I solved it (with code) is detailed at http://www.bhatt.id.au/blog/2004/07/26/fix-wordpress-rss-feeds/
    as its too long to post here
    Hopefully this helps other people reduce 404 errors and let Googlebot easily index their RSS feeds

  2. carthik
    Member
    Posted 9 years ago #

    You could have done it much easier with a rewriterule or two in your .htaccess file, to rewrite the google requests to your wp feed urls.

  3. Matt Mullenweg
    Troublemaker
    Posted 9 years ago #

    This is a bug in the Googlebot.

  4. Anonymous
    Unregistered
    Posted 9 years ago #

    >You could have done it much easier with a rewriterule or two in
    > your .htaccess file, to rewrite the google requests to your wp feed
    > urls.
    That is not the best option. I tried that already and google started to ask for
    /blog/feed/rss/rss.xml
    /blog/feed/rss/index.rdf
    /blog/feed/rss/atom.xml
    etc
    The trouble is that the link /blog/feed/rss/ does not tell a browser or other user agent (like search engine bots or feed readers) that the file type is xml, instead it looks like a directory.

  5. monkeynotes
    Member
    Posted 9 years ago #

    I get a 500 server error when I add this to my .htaccess file:
    <files rss.xml>
    ForceType application/x-httpd-php
    </files>
    <files rss2.xml>
    ForceType application/x-httpd-php
    < /files >
    <files index.rdf>
    ForceType application/x-httpd-php
    </files>
    <files atom.xml>
    ForceType application/x-httpd-php
    </files>

  6. Anonymous
    Unregistered
    Posted 9 years ago #

    Well, Mozilla Firefox has obviously no problem with the RSS feeds provided by WordPress... have you already contacted Google?

  7. Anonymous
    Unregistered
    Posted 9 years ago #

    i thought rss and atom were xml, why then is xml not the correct extention for them?

  8. Anonymous
    Unregistered
    Posted 9 years ago #

    My web host doesn't support .htaccess file, is there any other way to solve this problem?

  9. warthog
    Member
    Posted 7 years ago #

    where do I find my wordpress rss file?

  10. Chris_K
    Member
    Posted 7 years ago #

    I'm not sure a 2 year old unrelated thread was the best place to start...

    WordPress finds it for you. Have a look at WordPress_Feeds

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags