WordPress.org

Ready to get started?Download WordPress

Forums

FIx trackbacks! Please! (44 posts)

  1. Beel
    Member
    Posted 9 years ago #

    Actually it is your problem. I sent a trackback out and she received it - got it going and coming.

  2. Banagor
    Member
    Posted 9 years ago #

    Yeah, my outgoing trackbacks do not work either. They don't appear on the target site at all.
    Any fix in sight? A patch or something? This is fairly important. Actually, I don't care as much because I only trackback once every few weeks on average, but I'm sure that it would be nice for most people who are "normal" bloggers and need it every step of the way. :)
    So a patch would be really nice - especially since I just asked a lot of friends to convert from MT to WP. :) Don't make me look bad, please. :)

  3. Root
    Member
    Posted 9 years ago #

    I wish to heck I could help here but my trackbacks and pingback on 1.2 Mingus
    work just fine. It isn't the app causing this.

  4. Anonymous
    Unregistered
    Posted 9 years ago #

    Just 'cuz it doesn't work for you and a few others doesn't mean its the app. Just check all the "can't get to work" posts for just about everything. It works for me so it can't be the app, that's final. Need to check why it does not work for you.

  5. seriocomic
    Member
    Posted 9 years ago #

    Try RESETTING the Mod Rewrite rules by going into your admin, options, permalinks, checking the settings and CLICKING THE "UPDATE PERMALINK STRUCTURE" button.
    I had the same problems that you guys/girls had and this fixed it.

  6. Zootropo
    Member
    Posted 9 years ago #

    so you have to choose between s.e friendly urls and trackbacks? :/

  7. hanni
    Volunteer Moderator
    Posted 9 years ago #

    No, he means resetting it - start again withthe permalink rewrites then try the trackbacks.
    At least I think that's what seriocomic means!

  8. Kerim
    Member
    Posted 9 years ago #

    I thought I was having similar problems in 1.3, but it turned out that all my posts imported from MT were imported with trackback pings turned off. So, even though trackback was enabled for the blog, it was disabled for all the old posts. Just something people might wish to check before trying to solve permalinks or something more complex!

  9. Anonymous
    Unregistered
    Posted 9 years ago #

    I'm having the same problems. Trackbacks USED TO work with my blog (running WordPress 1.2) but they no longer do, and I'm not aware of having changed anything. Except maybe minor details in the template. Like the original poster I switched from MovableType, I absolutely need trackbacks and I don't understand what I might do to try to fix them. I don't have mod_rewrite on my server so can't try resetting that stuff.
    Trackbacks internal to my own blog seem to work.
    When I go to the trackback URL for a post on my blog I get an error message:
    Fatal error: Cannot redeclare class streamreader in ./wp-includes/streams.php on line 26
    I found this error in another support question that had nothing to do with trackbacks, and there there's a suggestion that a new build of wp-blog-header.php might help. I tried uploading the new build instead of my old one but that made my index page show as php code instead of being "interpreted" by the browser (it just showed the text of the code). Putting the old version of wp-blog-header.php back fixed that problem.
    I'm not very expert about php or servers, but I would love to have my trackbacks back and would really appreciate any ideas...

  10. Anonymous
    Unregistered
    Posted 9 years ago #

    I have find a solution that works fine for me. You can view it on my weblog:
    http://iozblog.ionosfera.com/archives/2004/08/29/wordpress_trackback_fix/

  11. Anonymous
    Unregistered
    Posted 9 years ago #

    I have find a solution that works fine for me. You can view it on my weblog:
    http://iozblog.ionosfera.com/archives/2004/08/29/wordpress_trackback_fix/
    I hope that it helps you.

  12. Anonymous
    Unregistered
    Posted 9 years ago #

    That worked beautifully! Thank you! And thanks for both explaining it well AND providing people like me who want things to work fast without being a programmer with the zip files to fix it fast!

  13. Anonymous
    Unregistered
    Posted 9 years ago #

    Using a text editor to add, remove, or move some lines of code doesn't constitute programming. There is an incorrect assumption that in order to use WordPress one needs programming skills.

  14. ihad
    Member
    Posted 9 years ago #

    it seems this still isnt fixed.
    my trackback uris generated by WP (nightly 09-05) look like this:
    http://www.ihad.de/wordpress/wp-trackback.php/19
    which will only result in a 404
    ai.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.