WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Fix for sliders in multisite? (10 posts)

  1. Kev CC
    Member
    Posted 1 year ago #

    Hi, This is my first post so excuse any faux-pas I may make.

    Is it possible to get a 'general'- fix for the multisite slider issue?? I seem to have a problem with every slider plugin I try.

    I've read a lot about various multisite/slider issues but all the advice is plugin specific. Maybe 'catch all' is ambitious, but is there a fix for multisite that addresses the various slider problems?
    I'm really pulling my hair out with this one!

    I'm a relative newcomer to WP, I first heard of it less than a year ago, but thanks to its flexibility, the amazing developers and extensive community support, I am now a lifelong WordPress disciple. Everything I have learnt so far has been through the community, Seriously Big Thanks!

    I have a WP 3.4.1 multisite install, with domain mapping.
    One of my mapped Domains uses a child theme of the Prospect theme which uses Nivo Slider. This works great - No Probs! - http://BCDbuild.com

    Another mapped subdomain uses a child of the pinboard theme (not sure what the built in slider is) but it also works fine, http://Digi-CC.com/web-design-digital-marketing/

    Now the problem seems to be with ANY other slider I try to use on the main site or the other subs:
    http://criticalcuriosity.com (main site)

    http://belfastcinema.criticalcuriosity.com/recent-reviews/ (nextGen Slider)

    is this a common issue with multi site? I'm at a total loss...
    Any advice would be greatly appreciated.

    Thanks

  2. It's a common issue when people don't write code correctly and assume everyone keeps image in /wp-content/uploads (pro tip, Multisite does not).

    TimThumb is notable for having this problem.

  3. Kev CC
    Member
    Posted 1 year ago #

    Thanks for the quick reply.
    So is there an alternative to TimThumb or should I be looking at changing the way the sliders get files?

    Like, instead of '/wp-content/uploads' should the slider/plugin(?) be looking in the blog directory or something?

    Apologies if I'm off the mark,
    My grasp on PHP is shaky at best but I can make some duct-tape modifications to theme files when needed...

  4. The funny thing is it's not hard to make TimThumb work: http://www.binarymoon.co.uk/2009/10/timthumb-wordpress-mu/ (one of the lead devs for TimThumb wrote that). it's just people don't do it for some reason. And in all fairness its not TimThumb, it's how people implement it.

    But there are a lot of sliders that work just fine with Multisite, so generally I'd get one of those, vs rewrite a whole lot.

  5. Kev CC
    Member
    Posted 1 year ago #

    Thank you! I'll have a look at that article!

  6. Kev CC
    Member
    Posted 1 year ago #

    Hi, I've had a look at the article and tried everything to get these themes/sliders working but cannot seem to get my head around it. Could you suggest some sliders that work in Multisite?

  7. http://wordpress.org/extend/plugins/slideshow/ worked last time I used it

    Also there's one in Jetpack

  8. Kev CC
    Member
    Posted 1 year ago #

    Hi, just checking in to say thank you, the slideshow plugin works great! I have been implementing it across the network.

    Although I think I may be using a more recent version by StefanBoonstra. (great plugin)

    Thank you again!

    Just wondering, could you recommend a 'posts/pages' slider that works in Multi-site? Something that shows an image with a content excerpt overlay on hover maybe?

  9. I use Genesis Slider for that, but I'm using their themes.

  10. Kev CC
    Member
    Posted 1 year ago #

    Thanks for the help! :)

Topic Closed

This topic has been closed to new replies.

About this Topic